Cannot open camera and microphone [Solved]

Hello there,

This is my first time to deploy jitsi on a server, so please forgive me if my questions look too basic.

My camera seems working because the camera light is on, but the camera and microphone buttons on jitsi are fixed. (I deployed jitsi on Azure following the instructions here: https://github.com/Yuchunchen/BuildYourOwnConferenceSystem)

I guess my problem is similar to another post: Cannot Access Camera & Audio

When I tried to access the log file, I got this response from Ubuntu.

jitsiadm@myjitsidemo:~$ /var/log/jitsi/jvb.log
-bash: /var/log/jitsi/jvb.log: Permission denied

More questions:
(1) If TLS is required, how to set up TLS in my server? (When I entered my deployed jitsit for the first time, I got the warning that this link was insecure. I still got the insecurity warning on the URL row when I opened the jitsi on my server.)
(2) How to share the jitsi on my server with my participants? (I opened jitsi on my Chrome with the url ‘jitsidemo.westus2.cloudapp.azure.com’. On my mobile phone, I installed jitsi and set the server as ‘https://jitsidemo.westus2.cloudapp.azure.com’, and I logged into a jitsi room. However, the two accounts are not in the same room! The server set on my phone did not work because when I wanted to invite others, the link began with ‘http://meet.jit.si/…’.)
(3) How can I know if I already have an FQDN? I tried to follow this document (https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#basic-jitsi-meet-install), but the FQDN part is confusing to me.

I would much appreciate it if anyone can help!