Cannot make secure domain work

Hi,

I have a self-hosted jitsi-meet, unstable branch, installation, that works on a server with debian unstable. Installation was performed following the quick installation guide. I also tried to create a secure domain, following the instructions in the configuration section of the guide.

When I type the username and password on the pop up menu in order to start a conference, the pop up menu keeps returning back asking for username and password again and again. So I cannot start a conference.

Without the secure domain changes in the coniguration, I can start and host a conference.

Attached are the relevant changed configuration files and the relevant log files.

Regards
Dimitris

Did you register the users after restarting prosody?

prosodyctl register ...

According to the coniguration guide, I executed the following commands in the order listed below:

  1. sudo prosodyctl register jitsi-meet.example.com
  2. sudo systemctl restart prosody
  3. sudo systemctl restart jicofo
  4. sudo systemctl restart jitsi-videobridge2

Do I have to run again

  1. sudo prosodyctl register jitsi-meet.example.com ?

The registeration should be after restarting prosody.

You may check /var/lib/prosody/ for the result.

I have the files

/var/lib/prosody/jitsi.meet.example.com/accounts/user1.dat
/var/lib/prosody/jitsi.meet.example.com/accounts/user2.dat

for the user1 and user2 that I have created (registered).

You need to repeat the modules_enabled section in the guest virtual host section. :slight_smile:

I have repeated the modules_enabled section in the guest virtual host section of the file /etc/prosody/conf.avail/jitsi.meet.example.com.cfg.lua, as:

VirtualHost “guest.jitsi.meet.example.com
authentication = “anonymous”
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“external_services”;
“conference_duration”;
“end_conference”;
“muc_lobby_rooms”;
“muc_breakout_rooms”;
“av_moderation”;
“room_metadata”;
}
c2s_require_encryption = false

but the problem persists.