Cannot login to jitsi-meet - "Strophe: Server did not offer a supported authentication mechanism"

Hi all,
My jitsi server worked fine and after an update I can no longer login. I cannot pnpoint which update as we don’t use the service every day and updates are done regularly but it stopped working at some point.

When I login now to jjtsi-meet which requires the host to authenticate to start a conference, I get an immediate :Oops something went wrong" error message with the non-nondescript message “connection:otherError”.

On the javascript console I see the following "“Strophe: Server did not offer a supported authentication mechanism”.

I have looked at the log files and there are no error message which appear in jicofo.log, jvb.log, prosody.log nor nginx error.log. I have disabled IPV6 n case that was a problem, and updated my ssl certs used by prosody but no luck.

Any ideas where to look?


1 Like

Check whether you have c2s_require_encryption = false(as in here for the virtual hosts you are using, if adding those does not help you can try adding consider_bosh_secure = true; to the general prosody config.

The entry “c2s_require_encryption = false” was already there. I added
“consider_bosh_secure = true”

I now get a different error “conference:connection.GET_SESSION_ID_ERROR”. Still nothing, as far as I can tell in the server logs. On the browser console I get

[modules/UI/authentication/AuthHandler.js] <i/</n</<>: authenticateAndUpgradeRole failed
authenticationError: “not-authorized”
​message: “not authorized user domain”

So I guess its got something to do with authentication, the original problem as well but not sure why. I can login with the userid via a xmpp client.

thanks for the help. I am completely out of ideas (

Which version are you running? We discovered these days a problem with authentication which was fixed today.
This update is available in latest unstable packages.
You have this in your jicofo config:
And when authenticating you are using as username?

I am on Ubuntu 16.04. According to apt I have the following versions installed.

jicofo/stable 1.0-417-1 i386
JItsi Meet COnference FOcus

jigasi/stable 1.0-175 i386
Jitsi Gateway for SIP

jitsi/stable 2.10.5550-1 amd64
VoIP and Instant Messaging client

I tried addin the line "" to /etc/jitsi/jicofo/config but it didn’t seem to have an effect.
I am logging in as -> I can login fine with an xmpp client. I cannot find the middleware.js file to edit as per the github page.

So you are on stable. The value “” should go in /etc/jitsi/jicofo/ as described here: GitHub - jitsi/jicofo: JItsi COnference FOcus is a server side focus component used in Jitsi Meet conferences.
“If you have Jicofo installed from the Debian package this should go directly to /etc/jitsi/jicofo/ file:”

I don’t understand this, what do you want to edit there?

Ah ok - thanks. The entry is already in the file. The only cusstom entry I made to try and solve this problem, i.e. to the config files that had been working before, was to add "component_interface = “"” to the prosody config file.

In an attempt to fix the problem I disabled IPv6 as the log files showed services attempting to connect to the local ipv6 address. Disabling IPv6 in sysctl.conf cause prosody not to start as it tired to connect to the ::1 ipv6 localhost interface which now no longer exists. Not sure if this is relevant. I have removed the entry and it still give the same error.

The middleware.js file as per the github link

This is the source code, you need to checkout source and compile it. Those files are not available in the binary debian package.

Ok I have reinstalled everything using stable on Ubuntu 18.04 and before enabling secure domains everything works. Once secure domains are enabled I get prompted for the host username and password but on login I just get kicked back to the “Waiting for host” dialog.

I assume the unstable patch fixes this?

Exactly, this is the fix.

1 Like

I have a question, when is the fix going to available in the Debian/Ubuntu stable package?

I was brought to the project by this tutorial : , which makes it very easy to install, but I am getting nowhere with the secure domain configuration from

I am on Ubuntu 18.04.

I just updated it. The fix is now in stable.

Hi, I’m new to Jitsi and programming, I will like to implement video call using jitsi on django. With a strophe client.
Can you please recommend how I can implement this or any tutorial that can help. Thanks

:sonrisa: hola! tengo el mismo error pero no entiendo nada de programación. hay algún modo sencillo para solucionar el problema? uso windows10.

Hello, i had the same issue and did what damencho said, added consider_bosh_secure = true; in the file, then i restarted this services: jicofo, videobridge2 and prosody in the server. Then i didnt have this issue again