Cannot get the new docker images set up a working system

Hi all,

First of all thank you to the developers for such an amazing software! I have been using Jitsi via Docker since the beginning of 2020 and did not have any major problems with it. Thank you!

My current working setup uses a docker image that was created on 2020-10-16 based on the information I got via docker image inspect command. I use it through docker-compose.yml and I have working .env settings. My server is behind a router, so only the ports 80, 443 and 10000 are forwarded to it from the router, since I don’t use SIP. I tried upgrading this setup via docker-compose pull and when I do that, I still get the containers created and launched as usual. Let’s Encrypt certificates are obtained without problem and when I open up the server address on the browser, the front page of Jitsi appears with the options of creating or joining a room. It is where the ball drops when I try to create or join a room. I get into an infinite loop of reconnection and disconnections without being able to do anything. I believe some update in the containers that were created later than the ones I use broke something for the particular settings that I use. I would very much appreciate guidance to help pin point the source of this issue so that I can use a more recent version of jitsi. I am happy to share my .env and docker-compose.yml files (with some redaction for security purposes) if these are needed.

Thanks in advance!

A good start of debugging problems is to obtain the js console logs from the browser so we can see the error and what is causing your issues.

Thank you for your guidance! Please excuse my ignorance on this but is it possible to get the js console logs from a closed browser session or should I recreate the situation to obtain these logs in the current browser session? I used chromium for this purpose if it helps. The issue I would run with the latter scenario is, when I use the latest docker images, I delete the ~/.jitsi-meet.cfg folder before launching the containers up and the new containers request a new Let’s Encrypt key pair. Once you exceed 5 requests an hour I believe, you would not be granted those keys until the next day or so. I am already at the count of 3 today, therefore hesitant to recreate the whole experiment :slight_smile:.

yep, you need to get it from live session

I am sorry for the late reply. It took me a while to try this again. Please see console logs from chromium. I could not decipher what the issue was. I tried joining a test meeting, which failed and waited for 15 secs for a reconnection attempt, which is included in the logs, perhaps like a repetition. I changed the real name of my server to https://jitsi.testserver.com in the logs for privacy reasons. Any input will be greatly appreciated.ChromiumConsoleLogsforJitsi.txt (192.4 KB)

To my uneducated reading the following lines may contain some pointers, but I am not sure if that is the case, nor do I know how to interpret them:

strophe.umd.js:5463 WebSocket connection to 'wss://jitsi.testserver.com/xmpp-websocket?room=testmeeting' failed: Error during WebSocket handshake: Unexpected response code: 403
_connect @ lib-jitsi-meet.min.js?v=5211:1
connect @ lib-jitsi-meet.min.js?v=5211:1
_interceptConnectArgs @ lib-jitsi-meet.min.js?v=5211:25
connect @ lib-jitsi-meet.min.js?v=5211:1
_connect @ lib-jitsi-meet.min.js?v=5211:1
connect @ lib-jitsi-meet.min.js?v=5211:1
c.connect @ lib-jitsi-meet.min.js?v=5211:10
e @ app.bundle.min.js?v=5211:152
(anonymous) @ app.bundle.min.js?v=5211:152
g @ app.bundle.min.js?v=5211:152
b @ app.bundle.min.js?v=5211:152
$ @ app.bundle.min.js?v=5211:193
createInitialLocalTracksAndConnect @ app.bundle.min.js?v=5211:193
init @ app.bundle.min.js?v=5211:193
Logger.js:154 2021-09-03T17:11:16.074Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>:  UnhandledError: Strophe: Websocket error [object Event] Script: null Line: null Column: null StackTrace:  Error: Strophe: Websocket error [object Event]
    at Object.s.Strophe.log (https://jitsi.testserver.com/libs/lib-jitsi-meet.min.js?v=5211:17:16531)
    at Object.error (https://jitsi.testserver.com/libs/lib-jitsi-meet.min.js?v=5211:1:24368)
    at N.Websocket._onError (https://jitsi.testserver.com/libs/lib-jitsi-meet.min.js?v=5211:1:63842)
o @ lib-jitsi-meet.min.js?v=5211:10
getGlobalOnErrorHandler @ lib-jitsi-meet.min.js?v=5211:17
window.onerror @ app.bundle.min.js?v=5211:418
callErrorHandler @ lib-jitsi-meet.min.js?v=5211:1
s.Strophe.log @ lib-jitsi-meet.min.js?v=5211:17
error @ lib-jitsi-meet.min.js?v=5211:1
_onError @ lib-jitsi-meet.min.js?v=5211:1
error (async)

Any guidance will be greatly appreciated!

Have you checked this Self-Hosting Guide - Docker · Jitsi Meet Handbook

Yes, that handbook has been my main reference from the first day, until it stopped working after an update by late 2020. Just for clarification, my server doesn’t have a reverse proxy setup, but it is behind a router, and the ports 80, 443 and 10000 are forwarded from it. I am probably missing something very simple or major here and I do appreciate your patience in dealing with me.