Cannot get lobby to work. Lobby is shown but no knock indication for participants

Moderator is able to enable lobby feature. People can ask to get in, but the moderator does not see any indication that someone is waiting. The meeting has no password set.
Followed instructions on: [How to] How do I use the new Lobby Feature? - #15 by migo

Any hint is highly helpful :slight_smile:

Installed versions:

> # dpkg -l | grep jitsi
ii  jitsi-meet                     2.0.5390-1                          all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody             1.0.4628-1                          all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-turnserver          1.0.4628-1                          all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web                 1.0.4628-1                          all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config          1.0.4628-1                          all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2             2.1-416-g2f43d1b4-1                 all          WebRTC compatible Selective Forwarding Unit (SFU)
# apt list -a prosody
Listing... Done
prosody/unknown,now 0.11.7-1~bionic4 amd64 [installed]

Config:

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }
-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "video.meet.de";

turncredentials_secret = "secret";

turncredentials = {
  { type = "stun", host = "video.meet.de", port = "443" },
  { type = "turn", host = "video.meet.de", port = "443", transport = "udp" },
  { type = "turns", host = "video.meet.de", port = "443", transport = "tcp" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
consider_websocket_secure = true;
cross_domain_websocket = true;

VirtualHost "video.meet.de"
        -- enabled = false -- Remove this line to enable this host
        authentication = "internal_plain"
        -- Properties below are modified by jitsi-meet-tokens package config
        -- and authentication above is switched to "token"
        --app_id="example_app_id"
        --app_secret="example_app_secret"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/video.meet.de.key";
                certificate = "/etc/prosody/certs/video.meet.de.crt";
        }
        speakerstats_component = "speakerstats.video.meet.de"
        conference_duration_component = "conferenceduration.video.meet.de"
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
            "speakerstats";
            "turncredentials";
            "conference_duration";
            "websocket";
            "muc_lobby_rooms";
        }
        c2s_require_encryption = false
        lobby_muc = "lobby.video.meet.de"
        main_muc = "conference.meet.de"

Component "lobby.video.meet.de" "muc"
    storage = "memory"
    restrict_room_creation = true 
    muc_room_locking = false 
    muc_room_default_public_jids = true   

VirtualHost "guest.video.meet.de"
    authentication = "anonymous"
    c2s_require_encryption = false

Component "conference.video.meet.de" "muc"
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "token_verification";
    }
    admins = { "focus@auth.video.meet.de" }
    muc_room_locking = false
    muc_room_default_public_jids = true



-- internal muc component
Component "internal.auth.video.meet.de" "muc"
    storage = "memory"
    modules_enabled = {
      "ping";
    }
    admins = { "focus@auth.video.meet.de", "jvb@auth.video.meet.de" }

VirtualHost "auth.video.meet.de"
    ssl = {
        key = "/etc/prosody/certs/auth.video.meet.de.key";
        certificate = "/etc/prosody/certs/auth.video.meet.de.crt";
    }
    authentication = "internal_plain"

Component "focus.video.meet.de"
    component_secret = "secret"

Component "speakerstats.video.meet.de" "speakerstats_component"
    muc_component = "conference.video.meet.de"

Component "conferenceduration.video.meet.de" "conference_duration_component"
    muc_component = "conference.video.meet.de"

Welcome to the forum. No, you do not need to set up the Lobby feature as it now comes pre-packaged in recent versions. You appear to be using the most current stable release - lobby is enabled by default there.

1 Like

My guess is that you have made a mistake in your host configuration.
it should be like that:

        lobby_muc = "lobby.subdomain.domain.tld"
        main_muc = "conference.subdomain.domain.tld"
1 Like

I am using this instance for nearly 2 years. So I upgraded and the config is not upgraded this way.

If you just upgraded, yes the lobby config has changed. Check out this post on how to fix it - FIX: Lobby Not Working After Upgrade to Latest Version (2.0.5390)

1 Like

Thousand thanks! The missing subdomain was the problem. :slight_smile:

One question: Is it possible to enable lobby as a default for all conferences?

now that’s a frequently asked question. I have no great interest in it myself, in one of those giant threads I had suggested a hack to do it but it did not find much echo and I did not follow up on it. Use the search, there may be other solutions.