Cannot connect to google calendar


#1

Hi there - I am on Ubuntu 18.04 (have tested with chromium and firefox), and I cannot connect with a google calendar. The popup comes up, and I log in, but nothing changes in the Jitsi interface.

A gif screen recording can be seen here: https://imgur.com/a/7YjjrJs

Ideas?


#2

Do you see any javascript errors in the developer console? (Right click the page, select Inspect, and go to the “Console” tab and look for red text.) Normally when you click on one of the calendar integration buttons an auth popup should open. If there is no error, do you have any popup blocking on that might be swallowing the auth popup?


#3

Before I tried anything (i.e. - just loading the page), there was:

content_script_bundle.js:13 Uncaught (in promise) ReferenceError: currentURL is not defined
    at then.catch.e (content_script_bundle.js:13)

Then I tried connecting to the calendar; no additional JS errors popped up - just the original as described above.


#4

Your steps are essentially “go to meet.jit.si”, “open settings”, “click one of the calendar integration buttons”? Do you have ghostery installed by any chance or any other extension that might interfere with google’s javascript api? I did a search on your error, as “currentURL” is not a variable used in jitsi-meet, and a ghostery result came up. I could reproduce your issue with ghostery installed.


#5

I did not have ghostery, but I went into any extensions that may have blocked anything and added a whitelist entry for meet.jit.si. All good now. It was either Privacy Badger, or Ublock Origin.