Cannot connect external users with jitsi-meet docker (behind NAT)

Hi everybody, I have installed according to the jitsi-meet instructions in docker (behind NAT), and I have the following problem, if I put in .env file

DOCKER_HOST_ADDRESS = 192.168.1.26 (IP docker host)
I can connect with users on the same network (192.168.1.xxx), but not with external ones.

If instead I put

DOCKER_HOST_ADDRESS = Public IP
It does not work for me with internal or external users.

Any suggestion? Thank you

After months of battles, I finally succeeded!

Solution

In the original docker compose file, disable the “Expose” section in the XMPP server and add:
ports:
- 5222:5222
- 5347:5347
- 5280:5280

configure ports on the router
Jitisi TCP 4443 to IP docker machine
Jitsi UDP 10000 to IP docker machine

I have change the names of docker container
docker-jitsi-meet_jicofo_1
focus.meet.jitsi

docker-jitsi-meet_jvb_1
video.meet.jitsi

docker rename my_container my_new_container

docker-jitsi-meet_web_1
meet.jitsi

docker-jitsi-meet_prosody_1
xmpp.meet.jitsi

NGINX Proxy reverse
server {
if ($host = meet.subdomain) {
return 301 https://$host$request_uri;
}

listen 80;
server_name meet.subdomain;
return 301 https://$host$request_uri;
}

server {
listen 443 ssl;
server_name meet.subdomain;
ssl_certificate /etc/letsencrypt/live/meet.subdomain/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/meet.subdomain/privkey.pem;

ssl on;
ssl_session_cache builtin:1000 shared:SSL:10m;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers HIGH:!aNULL:!eNULL:!EXPORT:!CAMELLIA:!DES:!MD5:!PSK:!RC4;
ssl_stapling on;
ssl_stapling_verify on;

access_log /var/log/nginx/meet_access.log;
error_log /var/log/nginx/meet_error.log;

location / {
proxy_pass http://IP_docker_machine:8000;
proxy_set_header X-Forwarded-For $remote_addr;
proxy_set_header Host $http_host;
}

}

change env file

Public URL for the web service

PUBLIC_URL=https://meet.domain
Enable authentication

ENABLE_AUTH=1
Enable guest access

ENABLE_GUESTS=1
Select authentication type: internal, jwt or ldap

AUTH_TYPE=internal

docker-compose exec prosody prosodyctl --config /config/prosody.cfg.lua register NAME meet.jitsi PASSWORD

I hope it is useful to you, I have used the base configuration of github for docker.

1 Like