Cannot build jitsi-meet client v5963

Hi guys!
I’m trying to install a new version of the jitsi-meet client (stable/5963).
And I have an error message when I’m trying to run npm update in jitsi-meet folder with the following text:

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: jitsi-meet@0.0.0
npm ERR! Found: react@16.12.0
npm ERR! node_modules/react
npm ERR!   react@"16.12" from the root project
npm ERR!   peer react@"^16.8" from @react-native-async-storage/async-storage@1.13.2
npm ERR!   node_modules/@react-native-async-storage/async-storage
npm ERR!     @react-native-async-storage/async-storage@"1.13.2" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer react@"16.9.0" from react-native@0.61.5-jitsi.2
npm ERR! node_modules/react-native
npm ERR!   react-native@"github:jitsi/react-native#891986ec5ecaef65d1c8a7fe472f86cf84fe7551" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See /Users/myuser/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/myuser/.npm/_logs/2021-08-02T08_22_14_798Z-debug.log

Ok, in the case when I don’t run npm update and instead of it run npm install and then make dev I get a message that

     WARNING in ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Positioner.js 15:24-39
    "export 'PositionerFixed' was not found in '../styled/Modal'
     @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Modal.js
     @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/ModalWrapper.js
     @ ./node_modules/@atlaskit/modal-dialog/dist/esm/index.js
     @ ./react/features/base/dialog/components/web/DialogContainer.js
     @ ./react/features/base/dialog/components/web/index.js
     @ ./react/features/base/dialog/components/_.web.js
     @ ./react/features/base/dialog/components/index.js
     @ ./react/features/base/dialog/index.js
     @ ./modules/keyboardshortcut/keyboardshortcut.js
     @ ./app.js

And when I try to open localhost I get a lot of errors in the js console.

I’ve tried to build the code on macOS and on ubuntu.
Node version on ubuntu was 14.16.0 (npm 7.6.2)
And on Mac I tried two versions of nodejs 14.16.0 (npm 7.6.2) and 16.6.0 (npm 7.19.1)

What am I doing wrong?

Seems that I should not launch npm update.
The message from make dev can be ignored (good question why?).