Can we Auto Record the meeting without Clicking "Start Recording" tool bar button

I trying to record the meeting as soon as the moderator joins the meeting automatically without clicking “Start Recording” tool bar button.

I tried the below reference but didn’t work out.

Does it work if you click start recording?

Yes, its works when click start recording.
We want to start the recording automatically as soon as meeting start without clicking start recording.

Perhaps check prosody logs to make sure the modules was loaded and there are no errors?

Also, are you using JWT auth and have the following claims in the moderator’s token?

  "context": {
    "features": {
      "recording": true
    }
  }

If I am reading the source correctly, then it looks like that is required for the recording to be triggered.

I tested it today and it works for me.

Which authentication method is enabled in your setup?

Did Recording started without clicking startRecording.

Not Sure about authentication method.
Can you tell me how check if authentication is enabled or how to setup the authentication.

Yep, it starts without clicking…

You may check your prosody config file which is /etc/prosody/conf.d/yourdomain.cfg.lua

I checked unable figure out what causing the issue where did the configuration went wrong.

Can you please tell step by step flow how to setup this.
Do I need to change anything here

image

I tried Below solution seeing Recording Failed error

image

Browser console error :

Can you please help me with this.

These are 2 different ways to start recording automatically. Don’t mix them.

Currently recording when startRecording is clicked but I want recording to start automatically don’t want to use “startRecording” via action or when person click startRecording.

Can you explain how did you install and configure jibri_autostart module?

Using this below commands

cd /usr/share/jitsi-meet/prosody-plugins/
wget -O mod_jibri_autostart.lua https://raw.githubusercontent.com/jitsi-contrib/prosody-plugins/main/jibri_autostart/mod_jibri_autostart.lua

Enable module in your prosody config.

/etc/prosody/conf.d/meet.mydomain.com.cfg.lua

Component “conference.meet.mydomain.com” “muc”
modules_enabled = {


“jibri_autostart”;
}

Is there any error in the prosody log?

/var/log/prosody/prosody.log

I don’t see any error’s

The server-side recording is disabled in your server. First, you need to solve it

Do I need to enable Local recording configuration?

/ DEPRECATED. Use recordingService.enabled instead.
// fileRecordingsServiceEnabled: false,

// DEPRECATED. Use recordingService.sharingEnabled instead.
// fileRecordingsServiceSharingEnabled: false,

// Local recording configuration.
// localRecording: {
//     // Whether to disable local recording or not.
//     disable: false,
//}

I enabled “recordingService” still same thing in prosody.log

The server-side recording is enabled on your server now but it fails when it is started manually. Before enabling this module, you must have a working server-side recording system