Can the IP address advertised by http-bind for port 10000 be specified in server configs?

Hi,
I have a jitsi server hosted at jitsiIP that i would like to expose through a reverse proxy at revProxyIP.

I’ve configured DNS for my.jitsi.site to point to revProxyIP & I’m using nginx stream directive to reverse proxy all the TCP and UDP ports needed.

When calling this url: https://my.jitsi.site/http-bind?room=a
I’m getting this: <candidate component='1' protocol='udp' generation='0' priority='2130706431' port='10000' network='0' id='586a02ac6f1f735401586cca9' foundation='1' ip='**jitsiIP**' type='host'/>

I am wondering if I can configure the advertised IP to be revProxyIP instead of jitsiIP, so that i can go thru a reverse proxy (nginx udp) throughout the conference,

It seems that prosody is binding 5280, but looking in its config i cannot see clearly a spot for IP advertised for media 10000.

I’m wondering if the DNS of my.jitsi.site has an impact…momentarily for locations in internet like my home, it is indeed bound to the reverse proxy, but doind host my.jitsi.side from the server running the jitsi stack, it is not being resolved. Do I need to fix that, or by adding it to /etc/hosts to point the the revProxyIP?
thank you

jvb learns its own public IP address either by turn protocol (default) or by setting it manually in sip-communicator.properties and then it’s found through prosody. Maybe you can try to fool the system by setting the address in sip-communicator.properties.

1 Like

Actually I am ok with JVB knowning its public IP as it is, i would just like that http-bind endpoint returns an XML which contains instead of:
<candidate component='1' protocol='udp' generation='0' priority='2130706431' port='10000' network='0' id='586a02ac6f1f735401586cca9' foundation='1' ip='**jitsiIP**' type='host'/>
this:
<candidate component='1' protocol='udp' generation='0' priority='2130706431' port='10000' network='0' id='586a02ac6f1f735401586cca9' foundation='1' ip='**revProxyIP**' type='host'/>
The rest is done in the reverse proxy i think…the clients will think the reverse is the server, jvb will think it is the server, but traffic would go thru the reverse proxy…

This ip is coming from jvb. Set it there

The proxy is added as candidate, but the initial server is also a candidate (with higher priority). It is indeed a public IP. Looks that i will need to rewrite the content in proxy.

the http-bind is prosody talking, and it’s giving information transmitted from jvb.