"Can not invite participant -- no bridge available" since last update (Debian 10)

Hello,

Going a bit crazy, since update from this :

jitsi-meet 2.0.4468-1
jitsi-meet-prosody 1.0.4025-1
jitsi-meet-turnserver 1.0.4025-1
jitsi-meet-web 1.0.4025-1
jitsi-meet-web-config 1.0.4025-1
jitsi-videobridge 1126-1
jitsi-videobridge2 2.1-183-gdbddd169-1

to this :

jitsi-meet 2.0.4627-1
jitsi-meet-prosody 1.0.4127-1
jitsi-meet-tokens 1.0.4127-1
jitsi-meet-turnserver 1.0.4127-1
jitsi-meet-web 1.0.4127-1
jitsi-meet-web-config 1.0.4127-1
jitsi-videobridge2 2.1-202-g5f9377b9-1

On Debian 10, with a public IP, no nat, no routing.

Got now this problem when I create a room and when somebody try to join me :

Jicofo 2020-06-03 16:13:27.612 AVERTISSEMENT: [110] org.jitsi.jicofo.bridge.BridgeSelectionStrategy.log() Failed to select initial bridge for participantRegion=null
Jicofo 2020-06-03 16:13:27.612 GRAVE: [110] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.

I followed some topics regarding this problem, but no one helped to solve this… Please, have a look to what I checked.

JVB password -> :white_check_mark:

grep JVB_SECRET /etc/jitsi/videobridge/config && grep ‘user.shard.PASSWORD’ /etc/jitsi/videobridge/sip-communicator.properties && grep password /var/lib/prosody/auth%2evideoconf%2dtest%2emydomain%2eorg/accounts/jvb.dat

JVB_SECRET=Gjz@HW1e
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=Gjz@HW1e
[“password”] = “Gjz@HW1e”;

To be sure, I forced again password with same one : prosodyctl passwd jvb@auth.mydomain.org

I verifyed here also : /etc/prosody/conf.d/videoconf-test.mydomain.cfg.lua

Component “jitsi-videobridge.videoconf-test.mydomain.org
component_secret = “Gjz@HW1e”

Admins users in Prosody -> :white_check_mark:

Component “internal.auth.videoconf-test.mydomain.org” “muc”
storage = “memory”
modules_enabled = { “ping”; }
admins = { “focus@auth.videoconf-test.mydomain.org”, “jvb@auth.videoconf-test.mydomain.org” }

Note that, just after update focus was replaced by focusUser.

Verify videobridge version -> :white_check_mark:
I was using first version, and after upgrade v2 was installed, but worked. To be sure it was not used, I removed (purge) jitsi-videobridge and reinstall videobridge2 with same configuration. It’s up and apparently fine.

Disabling Turnserver -> :white_check_mark:

Verifying API in jicofo and videobridge -> :white_check_mark:
grep apis /etc/jitsi/videobridge/config

JVB_OPTS="–apis=xmpp,rest"

Fun fact, here also, after update, xmpp was remove…

Disabling HEALTH_CHECK_INTERVAL -> :white_check_mark:
grep INTERVAL /etc/jitsi/jicofo/sip-communicator.properties

org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1

Checking firewall problem -> :white_check_mark:

I just remove every rules, still the same problem.

Important : I checked also files with my product environnement (which one is running fine on the old version), everything is exactly configured like my test environnement where I’ve got these problem.

Please, help…

Any help, please ?

Hi Julian,

not sure if i can help you, but yesterday i had the same effect on an ubuntu 18.04. Only adding the xmpp-API to /etc/jitsi/videobridge/config wasn’t enough this update. And looking in the logs, the bridge correctly registered.

Bit i found the following messages in /var/log/prosody/prosody.err, which were not logged before the update:

Jul 05 22:49:51 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

That lead me to

Maybe you have the same problem.