Can not hear or see the other members of the jitsi-meeting

Hello, can somebody help me with my jitsi-issue?

I justed installed a “Jitsi Meet”-server under “Ubuntu 18.04”, but if I start a jitsi-meeting
I can’t see or hear the other member(s) of the meeting.

If I open the developer tools (F12 on the keyboard) in “Google Chrome” I see the following error-message while the jitsi-meeting is running:
Logger.js:154 2020-10-08T14:12:32.100Z [modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel.

Does somebody know this issue and can help me?

Datax

Check advanced section of https://jitsi.org/qi it is a network problem.

Hello damencho, thanks for your reply.

I already followed this guide, but I still don’t know what is configured wrong.

The “Jitsi Meet”-server is not behind NAT, it has an own public IPv4-address.

How do I have to configure the following options in this case?

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

The Ubuntu-machine has only the loopback-interface “lo” and “eth0”. “eth0” has the public IPv4-address.

At the moment there are no firewall-rules active on the “Jitsi Meet”-server,
so all TCP/UDP-ports are open.

In the “/etc/hosts”-file I added the following line:
PUBLIC-IP-OF-JITSI-MEET-SERVER jitsi.MYDOMAIN jitsi

Of course there is the public IPv4-address instead of “PUBLIC-IP-OF-JITSI-MEET-SERVER” in the hosts-file. And of course there is my real domain instead of “MYDOMAIN” in the hosts-file.

On the client-side there is no firewall active, tool. The client is directly connected to a FritzBox with a dsl-connection.

Do I need to configure the option “org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES”?

Since the server isn’t behind NAT and no firewall, it should work with the default config.

No need the org.ice4j.ice.harvest.NAT_HARVESTER_* lines
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES is enabled

Yes, okay.

I just made a fresh installation of the ubuntu-machine.

But I still have the same issue.

Where to look what is going wrong?

Are you sure there is no firewall?
UFW or a firewall on the host provider?

how to check UDP/10000 connectivity

I tried this UDP-10000-check yesterday without problems.

But I will try this again now.

Here is the output of “iptables -L -n -v” on the ubuntu-machine (jitsi-meet-server):

Chain INPUT (policy ACCEPT 1 packets, 104 bytes)
pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

The “ufw”-firewall is not active on the ubuntu-machine.

ufw status
Status: inactive

The test with udp-port 10000 works without problems.

I can see " yes, it is accessable." on the ubuntu-machine.

Are the server and some clients in the same network?

No, the ubuntu-machine is hosted on a VPS-server in the internet with a public ipv4-address.

The clients which are used to connect to the jitsi-meeting are in my network at home behind
a FritzBox-Router (dsl-connection).

Do you use the host address which was set during the installation while connecting to the server?

Is there a valid TLS certificate for this host address?

Yes, I type the FQDN of the jitsi-server in my webbrowser to connect to it.

While installing the jitsi-server I received a “Let’s Encrypt”-certificate.

Are the outgoing IP and incoming IP the same on the server?

on server

curl ifconfig.me

on client

dig +short your.domain.com

Yes, the are the same.

I configured an A-record for the FQDN of my jitsi-server at my vps-hoster.

The ubuntu-machine only has 2 network-interfaces.
The one interface is the loopback-interface (127.0.0.1) and the other interface
is “eth0” with the public ipv4-address.

If I ping the FQDN (which I use to connect to the jitsi-server with my webbrowser)
I get the mentioned public ipv4-address.

This problem is really confusing me because the setup is really simple.

2020-10-09T09:26:32.533Z [modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel.
2020-10-09T09:26:32.533Z [JitsiConference.js] <u.sendMessage>: Failed to send E2E ping request or

Did you check the ifconfig.me too? This is important

What is the videobridge status?

systemctl status jitsi-videobridge2.service

And the resource?

free -m
lscpu

Output of “systemctl status jitsi-videobridge2.service”:

● jitsi-videobridge2.service - Jitsi Videobridge
Loaded: loaded (/lib/systemd/system/jitsi-videobridge2.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2020-10-09 10:33:26 CEST; 1h 11min ago
Main PID: 60409 (java)
Tasks: 51 (limit: 65000)
Memory: 247.8M
CGroup: /system.slice/jitsi-videobridge2.service
└─60409 java -Xmx3072m -XX:+UseConcMarkSweepGC -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Djdk.tls.ephemeralDHKeySize=2048 -Dconfig.file=/etc/jitsi/videobridge/jvb.conf -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties -cp /usr/share/jitsi-videobridge/jitsi-videobridge.jar:/usr/share/jitsi-videobridge/lib/* org.jitsi.videobridge.MainKt --apis=,

Oct 09 10:33:34 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:33:34 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:33:37 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:33:39 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:33:40 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:33:42 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:33:43 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:34:26 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:34:26 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
Oct 09 10:34:26 jitsi systemd[1]: /lib/systemd/system/jitsi-videobridge2.service:15: PIDFile= references a path below legacy directory /var/run/, updating /var/run/jitsi-videobridge/jitsi-videobridge.pid → /run/jitsi-videobridge/jitsi-videobridge.pid; please update the unit file accordingly.
root@jitsi:~#

root@jitsi:~# free -m
total used free shared buff/cache available
Mem: 3936 589 621 12 2725 3043
Swap: 0 0 0

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 46 bits physical, 48 bits virtual
CPU(s): 2
On-line CPU(s) list: 0,1
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 2
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 85
Model name: Intel® Xeon® Gold 5220 CPU @ 2.20GHz
Stepping: 7
CPU MHz: 2194.842
BogoMIPS: 4389.68
Hypervisor vendor: KVM
Virtualization type: full
L1d cache: 32 KiB
L1i cache: 32 KiB
L2 cache: 1 MiB
L3 cache: 24.8 MiB
NUMA node0 CPU(s): 0,1
Vulnerability Itlb multihit: KVM: Vulnerable
Vulnerability L1tf: Not affected
Vulnerability Mds: Not affected
Vulnerability Meltdown: Not affected
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1: Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2: Mitigation; Enhanced IBRS, IBPB conditional, RSB filling
Vulnerability Tsx async abort: Mitigation; TSX disabled
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss syscall
nx pdpe1gb rdtscp lm constant_tsc arch_perfmon rep_good nopl xtopology cpuid tsc_known_freq pni pclmulqdq s
sse3 fma cx16 pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand hypervisor
lahf_lm abm 3dnowprefetch invpcid_single ssbd ibrs ibpb stibp ibrs_enhanced fsgsbase tsc_adjust bmi1 avx2 s
mep bmi2 erms invpcid mpx avx512f avx512dq rdseed adx smap clflushopt clwb avx512cd avx512bw avx512vl xsaveo
pt xsavec xgetbv1 arat pku ospke avx512_vnni md_clear arch_capabilities

Yes, the output of the command “curl ifconfig.me” is the public ipv4-address of the ubuntu-machine where the jitsi-server is installed. It is the same address I connect to, when I type the FQDN of the jitsi-server in my webbrowser.

did you check if the problem could be with your clients that could have a firewall blocking port 10000, or the Fritzbox could block them. Can you try with 2 phones on a mobile network ?

Hello and thanks for your response @gpatel-fr.

I have found the reason for this issue.

It was a browser-addon in “Google Chrome” on the PC which I justed to start a jitsi-meeting which caused the problem.

With this addon enabled audio and video were not transfered while the jitsi-meeting was running.
The name of the mentioned browser-addon is “User-Agent Switcher and Manager”.

I tested a jitsi-meeting with two friends yesterday, it worked without any problems.
So we had a jitsi-meeting with three persons and audio + video worked great.

Thanks for your help @damencho, @emrah and @gpatel-fr.

Datax