Camera quality limited after update. Send Max 360p

Was evaluating Jitsi for a 15 person ballet class video lesson.
Just purchased a 60" 4k TV for this reason.
This “downgrade” to 360 quality for all is confirmed? Any way to configure better quality at least for the teacher?
If 360 will be the max the only benefit (apart being FOSS) vs a commercial service (Zoom, BlueJeans we tested) will be (maybe) the reduced latency due to finding (or setting up) a nearby server.

My quick hack to force quality is to disable simulcast (2 occurrences in config.js) and to manually set the desired resolutions (Also 2 occurrences in confis.js)

It is not ideal, but it is the only way I found that ensures 1080p is sent-out

We recently made a change where we check the height of the video thumbnail for deciding on the resolution to be requested, making it harder to request higher resolutions in tile view. In order to receive 360p, the height of the thumbnail should be atleast 360 pixels. You can override this behavior by specifying your own thresholds using minHeightForQualityLvl setting in config.js.

If you want higher resolutions to be requested, you can lower the thresholds needed for requesting SD and HD resolutions - https://github.com/jitsi/jitsi-meet/blob/master/config.js#L277

Oh! That is a neat trick!
Do we need to un-comment the entire block, starting at // videoQuality: { ???
Also, do all parameters need to be populated to make it work, or can I keep some commented to run as default? (bit rate, codec, etc)

Also, you might know the answer to these questions:

  1. Why is the video quality constraints repeated in the config.js file? I fill-out both section to make sure, but is there one that take-over the other?

  2. Why is it that now, even if I disable simulcast and force the video in 1080p I often get a resolution in-between 720p and 1080p (980 or something like that) ?

You have to uncomment the block and leave the other parameters commented.

What quality constraints are you talking about ?

When you say you get in-between resolution, you have to be more specific about whether its send side or receive side as it can mean 2 different things.

Question about Video quality constraints:

In the config.js file, there are 2 sections about video quality, with more-or-less the same information:
First section:

Second section

Question about in-conference resolution
Whatever I do about requested video quality, and considering that I am on a gigabit Internet Link on both ends, even If my Camera is 1080p, in jitsi-meet I output at 980p or something like that, and the person on the other end receives this quality too (simulcast is disabled because of quality issues)

EDIT: If I am on P2P, I get the full 1080p stream on both ends, as soon as a third person joins and we switch on the server, the quality drops to 980 something

You are using the Docker setup, right? Then you can ignore the first part because it’s overridden by the second one.

It could be due to bandwidth / CPU. You are receiving twice as much data, and processing it. Chrome may choose to scale your local video down to try and help.

Yes I am, and honestly, once you iron-out the quirks, it is in my opinion the best way to deploy Jitsi! So simple, so fast! (once you pulled-out every hair on your head setting it up the first time of course!)

Thanks for the tip, I will ignore the first bit then.

This behavior did not occur in older version of Jitsi-meet… It has started happening once the developers have started working on the resolution bit of the platform… (and I was forced to disable simulcast)

Hello

I started jitsi meet with kubernetes.
I am based on this project:

I manually applied the content of the latest commits to support websockets.
It works in my kubernetes cluster.
However, I have errors for the E2E ping.
As well as the video quality for the remote participant remains fixed on 320x180 on my PC.
This is of course produced for all participants regardless of the PC.
I configured the new limits as mentioned above, disabled simulcast.
I am at the end of the solutions

Do you have an idea ?

Thank you

Hi,

I noticed today that there were 2 occurrences for “disableSimulcast”.
I hadn’t changed the correct value …

Set “config.disableSimulcast = true;” at the end of the “web-configmap.yaml” file for HD quality to return while jitsi fixes the bug.

I’ve disabled simulcast in docker-jitsi and tried all workarounds in this thread - still can’t get past “send max 360p”.

The following env vars are set

ENABLE_SIMULCAST=0

RESOLUTION=720
RESOLUTION_WIDTH=1280
RESOLUTION_MIN=360
RESOLUTION_WIDTH_MIN=320

My config files do not have lines looking like this… what version of jitsi-meet are you using?
You migh want to do a full search on the config file as resolutions and simulcast happen many times in the file…
There are also last-n functions that can interfere with the requested resolutions

These are env vars for Jitsi via docker. They finally populate into config.js mentioned before. But even when changing them in config.js and mounting this file as a volume, I can’t get it working.

I’ve checked all all simulcast instances & friends already.

I am running jitsi in docker too and there are a few settings that hurt quality…
You have this block (I am tempted to try the layer suspension option one day!):

This one I disabled because I don’t want anyone to have video muted whatever the amount of users in the conference

And there is this lower in the page:

I will take some time to debug simulcast on docker later this week as I am pretty certain it has to do with the fact that network capability of users is not read correctly

1 Like

Oh… and also, make sure you test with 3 people in the conference or with P2P disabled as you won’t be testing the same thing if you don’t :wink:

1 Like

Thanks @Normand_Nadon! It appears to work now.

Strange although that this is so hard to achieve and not well documented.

Also while I can understand the default settings from the Jitsi side, they also lead to a bad first experience when using Jitsi the first time.

I’d think that reducing resolution is a task for the admin (if needed) - given that most people run it on a cloud instance with enough resources and should be fine with no reduction.

Good news, simulcast works great at the moment on the docker stack ! :slight_smile:

I have set my resolution settings to 1080p ideal and 240p min and quality oscillates depending on client and server loads!

I had issues with that for the last few months

@damencho @saghul i am changing resolution using manage video quality slider but some time it not changing resolution and changed the send max 240p but i want to change the 640X360 to 427X240(send max 240p). send max is always changing according to action and it working perfectly. but resolution is not changing so bandwidth consumption is same. please let me know how to reduce or increase according to slider.

image

The send resolution depends on a lot of other factors as well. Do you have simulcast enabled ? Is this for a p2p call or for call involving 3 users ? Also what is the camera capture resolution ?