Camera quality limited after update. Send Max 360p

Hi guys, just wondering if this is a new feature and where can I disable it? I did an “apt upgrade” recently and now I notice when I login to a meeting and turn on my camera the resolution is limited to “640 x 360 (send max 360p)”. I’ve never seen that message before. Before the update I would normally connect at 1080p 30fps. I also noticed others are lower quality and the mobile app on Android never goes above 480x640 where I used to see higher resolutions on the mobile app also. Is the resolution for mobile app configurable because I could not find options for it in the app.

Thanks

The mobile app has been hardcoded to 360p for a while now. We are experimenting with it since it provides better performance.

HI @saghul, 360p or 480p? I had two mobile clients today and both were 480x640. That’s not as big a deal though as the message I see on the PCs with Chrome “send max 360p”. Where is that coming from? The webcams are Logitech C920’s and are usually 1080p 30fps. One of great things about Jitsi Meet is calls are not limited to 720p like most popular services

Mobile is set to 360p.

I know lots of work went into making sure we don’t send more video that is needed (on web). So sending 360p may mean the receiver doesn’t have a large enough viewport, they are using tile view or manually managing call quality with the slider. Could this be the case?

@saghul I just testing with 4 clients in 3 different countries just to make it a real experience. When we were all on full screen and I was talking I was sending 1080p@30. When only one of the others changed to tile view MY stream changed to 360p for everyone. Is that normal?

Were all in tile view at that point? @jallamsetty do you know if this expected here?

No, only 1 client went to tile view but it made my feed change to 360p for me and everyone else

My users noticed that quality in general has decreased since upgrading. Any thoughts on how to return to better quality of past builds?

@brimur, this shouldn’t be happening. If only 1 client switches to tile view, the other clients should continue to receive the HD streams if they are in stage view. Are you able to reproduce this on meet.jit.si or is it happening only on your deployment ? I couldn’t reproduce this behavior on meet.jit.si.

Can verify this issue.
When NOT in tile view our resolution is normal (720p).
As soon as we go into tile mode the resolution gets limited at 360p.

This behaviour is new to the latest update(s), we had no problems with quality for months now.

This is the desired behavior. The sizes are calculated and you receive the layer which is suitable for this thumbnail this is to save on bandwidth and if nobody is watching you in 720p we drop that from the client for sending it for saving upload bandwidth and client CPU time.

How to overwrite this “desired behavior” ? We had this in our config:

resolution: 480,

constraints: {
video: {
aspectRatio: 16 / 9,
height: {
ideal: 480,
max: 480,
min: 240
}
}
},

for at least 8 months now and it worked fine. Don’t know why the newest update thought it would be a good idea to make the quality absolute crap by default.

Edit: To clarify: I’m talking about desktop/web, not mobile

This:
image
was NEVER limited to 360p (since we set it to 480p in config)

My Quality-Settings are not the problem, they are set to highest.

and this issue is 100% reproducable on other clients.

@EnCz, you can disable this behavior by disabling enableLayerSuspension in your config.js.

On a new installation enableLayerSuspension is commented out.

// enableLayerSuspension: false,

Is the default behavior (when enableLayerSuspension is commented out) for Layer Suspension to be disabled or enabled?

The default behavior when its commented out is to be disabled. If you haven’t updated already to the latest stable packages that were released yesterday, please do so. There was JVB bug that got fixed which was causing all sorts of quality issues.

Thanks for this. Would you recommend simply updating via apt?

Yes.

1 Like