Camera (Jitsi Meet) is not working in Mac safari browser

Jitsi Meet is failed to access the camera in the Mac safari browser.
Please help me to fix the issue

2 Likes

Once you are in a meeting, you can also authorize audio/video devices in the Settings menu.

Does this work for you ?

Not able to allow camera settings,

image

1 Like

My next advice would be to try with Chrome. Unfortunately I don’t use macOS so I can’t help more with Safari. Chrome provides the best experience so far, while Firefox is very close to providing the same.

Work for other browsers is ongoing, see this issue report.

In macOS Jitsi meet is working on Chrome and Firefox,
but in Safari meet is not working (camera is not working)
When call starts in Mac safari browser below error is showing(image attached)
image

2 Likes

Don’t use Safari.

most of our users are using Mac, and their default browser is Safari.
I can’t forcefully tell them to install the Chrome browser.
is there any other options to fix this issue?

2 Likes

My time here when answering is limited, that is why I suggested reading through the issue report about browsers support.

I took some more time today, as it turns out in macOS Safari has system settings that need adjusting to let the browser get permissions for audio and video on your webcam.

See (don’t forget to check/change the macOS version at the top):

Please come back and report here if this worked so I can properly document it. Thanks in advance!

I have had the same problem regarding Safari 13.1 on High Sierra version of Macos

Regarding Safari 13.1 on Catalina version of Macos it is woking fine

On High Sierra, do the test with the browser Chrome, it works fine

Best regards

I’m having the same issue here: MacOs Catalina - Safari - everything up to date.
@MagicFab I have ran through all the options on the link you provided. But the site never requests permission to use the camera in the first place.
The error message I get is:
Failed to access your camera
Your camera does not support required video resolution

The console displays the following error:

2020-05-19T13:58:07.757Z – "[modules/RTC/RTCUtils.js]" – "Failed to get access to local media. OverconstrainedError: Invalid constraint [object Object] "
2020-05-19T14:01:55.794Z – “[features/base/tracks]” – “Failed to create local tracks” (2)
[“video”] (1)
s {gum: Object, name: “gum.unsupported_resolution”, message: "Video resolution is not supported: ", stack: “s@https://web-cdn.jitsi.net/meetjitsi_4109.763/lib…4092.741:1:91976↵promiseReactionJob@[native code]”}
error
o — Logger.js:173
o
(função anónima) — functions.js:123
promiseReactionJob
s — Logger.js:182

@jallamsetty :eye:

@Philippe_de_LUZY, if the same set of constraints work on Safari 13.1 Catalina but don’t work on High Sierra, I would suspect its a webkit bug. Some other users have complained about the same on older models of macbook pros. Please check this one -
https://bugs.webkit.org/show_bug.cgi?id=210932

@filipejsbrandao, can you pls run this code on the browser console and tell us what o/p do you get ?
(async () => {
try {
const filter = ({width, height}) => ({width, height});
const stream = await navigator.mediaDevices.getUserMedia({video:{}});
const [track] = stream.getVideoTracks();
console.log(Capabilities: ${JSON.stringify(filter(track.getCapabilities()), null, 2)});
console.log(Settings: ${JSON.stringify(filter(track.getSettings()), null, 2)});
} catch(e) {
console.log(e);
}
})();

I get the following error:

SyntaxError: Unexpected token ':'. Expected ')' to end an argument list.

Sorry about that, there was a typo

(async () => {
try {
const filter = ({width, height}) => ({width, height});
const stream = await navigator.mediaDevices.getUserMedia({video:{}});
const [track] = stream.getVideoTracks();
console.log(Capabilities: ${JSON.stringify(filter(track.getCapabilities()), null, 2)});
console.log(Settings: ${JSON.stringify(filter(track.getSettings()), null, 2)});
} catch(e) {
console.log(e);
}
})();

This is what I see:
[Log] Capabilities: {
“width”: {
“max”: 1280,
“min”: 1
},
“height”: {
“max”: 720,
“min”: 1
}
}
[Log] Settings: {
“width”: 640,
“height”: 480
}

Lösung: gehe zu Safari-Einstellungen-Websites: hier kannst Du einzelnen Seiten erlauben, die Kamera und das Mikrofon zu benutzen.