Camera error until another participant joins

I saw a problem that is manifesting both on and on a website I am building. When a meeting is started, the first person sees an error for the camera, even though everything works.

The screen is blank and it seems that the camera is not working. However, after the second participant joins, everything works. It may be just a rogue error message, but it is confusing and it looks like the camera is not working for the first participant.

Is there a fix or a bug reported for this?


I can’t replicate this. Seems like it might be specific to your machine. Have you tried with another browser? What about testing on another machine?

Have you tried to use Chrome in incognito mode? Just to test if something might go wrong when you use Chrome under your regular account.

Tried the following:
Chrome, not incognito - Error
Chrome, incognito - Error
Edge, not incognito - Error
Edge, incognito - Works

Brave Mobile - Works
Chrome Mobile - Works

I attached the logs from the Chrome developer console here: chrome-logs -

The thing is that that everything works in the pre-meeting screen (the one where I enter my name)

If Edge works, Chrome should work. Since Edge works in incognito, if you clear the cache, it should work without incognito (and so should Chrome). Try clearing the cache completely on both browsers and test again. And as previously advised, test on another machine, if possible.

You are always going through pre join page, right?

Clearing the cache completely solved the problem. Thanks