Calendar Not Working - Have Done Everything I can think of

Jitsi Calendar is not working for me.

OK, as far as I can see, Jitsi Calendar is not working.

Here is what I did:

  1. Log into a Google admin account., OK did that
  2. Go to Google cloud platform dashboard., Did this
  3. In the Select a Project dropdown, click New Project. Did this
  4. Give the project a name. Called it Politea Jitsi Calendar
  5. Proceed to the Credentials settings of the new project. Did this
  6. In the Credentials tab of the Credentials settings, click Create Credentials and select the type I selected OAuth and this was the result: OAuth Client ID looks something like:, I am not providing the actual ID here.
  7. Proceed with creating a Web application and add the domains (origins) on which the application will be hosted. Local development environments (http://localhost:8000 for example) can be added here. I used for this and the Client ID is the same For authorized JavaScript origin I used 1 because I didn’t know what else to use here.
  8. While still in the Google cloud platform dashboard, click the Library settings for the calendar project.
  9. Search for the Google Calendar API (used for calendar accessing), click its result, and enable it. Did this, it is enabled
  10. Do the same for YouTube Data API v3. Did this it is also enabled.

I added the Client ID in and enabled Calendar Integration.

enableCalendarIntegration: true,


I restarted Prosody, JVB, Jocofo and Jitsi.

And this caused Jitsi to stall or crash.

Can anyone suggest what I did wrong?

According to Google, I need to add a Privacy Policy and Terms of Service Agreement somewhere on the Jitsi landing page so that it is easily visible and I need to include certain language in those agreements to satisfy Google. The only way I see to do that is to modify the code. I can add those agreements to the /usr/share/jitsi-meet/static folder, but I will have to create the links on the landing page.

Could someone tell me where I can find the code for the Jitsi landing page? I have looked on /usr/share/jitsi-meet/ but have found nothing that looks like the Jitsi landing page.

try redirect to without /static/oauth.html. It solved the problem for me.

Thanks, would have never thought of that.