Calendar integration

Confused about one piece of the calendar integration between jitsi and Exchange. The jitsi information says the user will see the meetings on jitsi, but there’s no login or account for jitsi. Once jitsi has access to my Exchange data, where does it live, and how would i see it? This pertains to the and pages, not to embedding jitsi into my own web site.

You should be able to see it on welcome page,

That’s my point. There’s no login to that page. The only way the server would recognize me is by persistent cookies. So are you saying that the only way to have the calendar show on that page is to use the same browser all the time and not to delete cookies on exit? (Also, where would the Exchange calendar data live, and under what protections?)

You just connect from settings and the calendar will be populated. Nothing lives outside of the memory of the current tab, only your browser is authenticated to access your calendar. Everytime you open the page the calendar is queried to get the data.

I have created a Google App ID for connecting jitsi with Google calendar and these are the scopes email

Anded these line Jitsi config file

enableCalendarIntegration: true,
googleApiApplicationClientID :“”,

“sign in with Google” button is appearing but when I clicked on that button nothing is happening no any pop-up window Nothing

Do I have to add redirect URL during app creation? But that’s not mentioned in the documentation.

Is the redirect url in google console correct?

Thank for the quick respond
Authorized redirect URIs is:

So this URL is correct? How can I solve this issue?

I’m getting this error in the console.
{error: “idpiframe_initialization_failed”, details: “Not a valid origin for the client: https://confere…itelist this origin for your project’s client ID.”}

This is the screenshot of

Google Console

In Firefox is says:

Object { error: “idpiframe_initialization_failed”, details: “Not a valid origin for the client: has not been whitelisted for client ID Please go to and whitelist this origin for your project’s client ID.” } but I can’t any whitelist option at