Button "ask to unmute"

Screenshot from 2021-12-09 15-11-16

On my selhosted instance, noting happens when the Moderator clicks it. What is missing?

ii  jicofo                1.0-830-1           all          JItsi Meet COnference FOcus
ii  jitsi-meet            2.0.6689-1          all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody    1.0.5638-1          all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-web        1.0.5638-1          all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config 1.0.5638-1          all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2    2.1-592-g1e2879e0-1 all          WebRTC compatible Selective Forwarding Unit (SFU)
ii  prosody               0.11.4-1            amd64        Lightweight Jabber/XMPP server

Java 11
Ubuntu 20 Server

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "{{ jitsi_domain }}";

external_service_secret = "FOOOOO";

external_services = {
     { type = "stun", host = "{{ stun_domain }}", port = 443 },
     { type = "turn", host = "{{ turn_domain }}", port = 443, transport = "udp", secret = true, ttl = 86400, algorithm = "turn" },
     { type = "turns", host = "{{ turn_domain }}", port = 443, transport = "tcp", secret = true, ttl = 86400, algorithm = "turn" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
https_ports = { }; -- Remove this line to prevent listening on port 5284

ssl = {
    protocol = "tlsv1_2+";
    ciphers = "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384"
}

unlimited_jids = {
    "focus@auth.{{ jitsi_domain }}",
    "jvb@auth.{{ jitsi_domain }}"
}

VirtualHost "{{ jitsi_domain }}"
    authentication = "internal_plain"
    ssl = {
        key = "/etc/prosody/certs/{{ jitsi_domain }}.key";
        certificate = "/etc/prosody/certs/{{ jitsi_domain }}.crt";
    }
    speakerstats_component = "speakerstats.{{ jitsi_domain }}"
    conference_duration_component = "conferenceduration.{{ jitsi_domain }}"
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "av_moderation";
        "muc_breakout_rooms";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.{{ jitsi_domain }}"
    main_muc = "conference.{{ jitsi_domain }}"
    breakout_rooms_muc = "breakout.{{ jitsi_domain }}"

VirtualHost "guest.{{ jitsi_domain }}"
    authentication = "anonymous"
    c2s_require_encryption = false
  modules_enabled = {
    "bosh";
    "pubsub";
    "ping"; -- Enable mod_ping
    "speakerstats";
    "external_services";
    "conference_duration";
  }

Component "conference.{{ jitsi_domain }}" "muc"
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
         "polls";
         "muc_rate_limit";
        -- "muc_allowners";
        --"token_verification";
    }
    admins = { "focus@auth.{{ jitsi_domain }}" }
    muc_room_locking = false
    muc_room_default_public_jids = true

-- internal muc component
Component "internal.auth.{{ jitsi_domain }}" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";
    }
    admins = { "focus@auth.{{ jitsi_domain }}", "jvb@auth.{{ jitsi_domain }}" }
    muc_room_locking = false
    muc_room_default_public_jids = true

Component "breakout.{{ jitsi_domain }}" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        --"token_verification";
        "muc_rate_limit";
    }
    admins = { "focus@auth.{{ jitsi_domain }}" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.{{ jitsi_domain }}"
    ssl = {
        key = "/etc/prosody/certs/auth.{{ jitsi_domain }}.key";
        certificate = "/etc/prosody/certs/auth.{{ jitsi_domain }}.crt";
    }
    modules_enabled = {
        "limits_exception";
    }
    authentication = "internal_hashed"

-- Proxy to jicofo's user JID, so that it doesn't have to register as a component.
Component "focus.{{ jitsi_domain }}" "client_proxy"
    target_address = "focus@auth.{{ jitsi_domain }}"

Component "speakerstats.{{ jitsi_domain }}" "speakerstats_component"
    muc_component = "conference.{{ jitsi_domain }}"

Component "conferenceduration.{{ jitsi_domain }}" "conference_duration_component"
    muc_component = "conference.{{ jitsi_domain }}"

Component "avmoderation.{{ jitsi_domain }}" "av_moderation_component"
    muc_component = "conference.{{ jitsi_domain }}"

Component "lobby.{{ jitsi_domain }}" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true

The other participant should get a notification, don’t they?

That is exactly what is not happening!

Which browser?

I tried FF 95 and Chrome 96; feature works on meet.jit.si
[edit:] Fun Fact: It works with the stable Version from last week, before the update.

I have av_moderation_component line before speakerstats_component in my prosody config.

VirtualHost "jitsi.mydomain.corp"
    ...
    ...
    av_moderation_component = "avmoderation.jitsi.mydomain.corp"
    speakerstats_component = "speakerstats.jitsi.mydomain.corp"
    conference_duration_component = "conferenceduration.jitsi.mydomain.corp"
1 Like

Hi @saghul , this is “The other participant should get a notification, don’t they?” same happening with me also and version of my chrome browser is 103+.

Do you have the avmoderation plugin configured?

are you talking about these files:
1.resources/prosody-plugins/ mod_av_modration.lua.
2.resources/prosody-plugins/ mod_av_modration_component.lua.

so I did not modify any of those files. I am working on “jitsi-meet-stable-jitsi-meet_7439” version of jitsi-meet .


Yes it’s those files. You need to have them enabled in your VirtualHost.