Build my own SDK artifacts/binaries

Hi all,

sorry for the dumb question. I’d like to modify something in the UI (specifically, I need to hide the menu option accessible via the “three dots” button). To this purpose, I have to ri-compile the source. I tried to follow the README file, but when I run the release-sdk.sh only react-native-0.61.1.aar is uploaded to my private maven repo. For this reason, my android app can’t resolve the dependency for org.jitsi.react:jitsi-meet-sdk:+. What am I doing wrong?

Thanks.

I saw right now that the above mentioned script gives this error:

./android/scripts/release-sdk.sh: line 44: pushd: /Users/vinx/jitsi-meet/android/scripts/…/…/node_modules/jsc-android/dist/org/webkit/android-jsc/r^245459: No such file or directory

the problem seems to be the “hat” character because the needed file is present but its name doesn’t have that character. How can I fix, please?

Ok, I’ve done another step further. I deleted node_modules directory and launched again npm install. Now, the directory name is correct (it doesn’t have the hat character), the process didn’t give me the previous error, but the deploy fails again…this time for a permission issue (the private repo returns the 401 status). So, I have two questions:

  1. Why does the deploy of both react-native and android-jsc terminate successfully, whereas the deploy of jitsi sdk fails?
  2. How can I modify the deploy script to authenticate myself at the private maven repo?

thanks again…and sorry for my bad english.