Build error in jitsi android - import groovy.json.JsonSlurper

Jitsi android cannot be built due to the following error. Anybody can help me solve this problem?

import groovy.json.JsonSlurper
import org.gradle.util.VersionNumber
...
        if (project.name.startsWith('react-native-')) {
            def npmManifest = project.file('../package.json')
            def json = new JsonSlurper().parseText(npmManifest.text)

Build file ‘C:\Project\jitsi-meet\android\build.gradle’ line: 106

A problem occurred configuring project ‘:react-native-amplitude’.

C:\Project\jitsi-meet\node_modules@amplitude\react-native\package.json (The system cannot find the path specified)

Windows is not supported, sorry.

1 Like

Thanks for your answer and the resource.

I tried on another OS system, Ubuntu 20.04:

But, it still shows errors even though it is not the same one.

Could not resolve all dependencies for configuration ‘:app:debugRuntimeClasspath’.
Could not create task ‘:app:minifyReleaseWithR8’.
Cannot query the value of this provider because it has no value available.

(For memo) The error above is currently solved. After add device in AVD manager, it has been gone away.