Build Develop environment from source on ubuntu with Visual code


#1

Hi @damencho,
I try to rebuild source fomr git on ubuntu 16.4 with Visual Code.
But i have some issue:

  1. So many error “[ts] ‘type’ can only be used in a .ts file”
  2. Error when debug.
    at Function.Module._load (module.js:498:3)
    at Function.Module.runMain (module.js:694:10)
    at startup (bootstrap_node.js:204:16)
    at bootstrap_node.js:625:3
    Waiting for the debugger to disconnect…
    SyntaxError: Unexpected token export
    vm.js:80
    at createScript (vm.js:80:10)
    at Object.runInThisContext (vm.js:139:10)
    at Module._compile (module.js:617:28)
    at Object.Module._extensions…js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)
    at Function.Module.runMain (module.js:694:10)
    at startup (bootstrap_node.js:204:16)
    at bootstrap_node.js:625:3

Pls, tell me how can fix it?
Thanks


#2

What does it happen building from console? What are the node and npm version? Try using the latest LTS versions from https://nodejs.org.


#3

Hi @damencho,
nodejs version 8.12.0
npm version 6.4.1

i run make successfull.
Console Debug:
/usr/bin/node --inspect-brk=37653 modules/API/index.js
Debugger listening on ws://127.0.0.1:37653/f34231b5-34f1-4638-983f-82204b2435a4
Debugger attached.
/home/quyet/covavi/project/jitsi-meet/modules/API/index.js:1
(function (exports, require, module, __filename, __dirname) { export default from ‘./API’;
^^^^^^
SyntaxError: Unexpected token export
at createScript (vm.js:80:10)
at Object.runInThisContext (vm.js:139:10)
at Module._compile (module.js:617:28)
at Object.Module._extensions…js (module.js:664:10)
at Module.load (module.js:566:32)
at tryModuleLoad (module.js:506:12)
at Function.Module._load (module.js:498:3)
at Function.Module.runMain (module.js:694:10)
at startup (bootstrap_node.js:204:16)
at bootstrap_node.js:625:3
Waiting for the debugger to disconnect…
SyntaxError: Unexpected token export
vm.js:80
at createScript (vm.js:80:10)
at Object.runInThisContext (vm.js:139:10)
at Module._compile (module.js:617:28)
at Object.Module._extensions…js (module.js:664:10)
at Module.load (module.js:566:32)
at tryModuleLoad (module.js:506:12)
at Function.Module._load (module.js:498:3)
at Function.Module.runMain (module.js:694:10)
at startup (bootstrap_node.js:204:16)
at bootstrap_node.js:625:3rd_place_medal:

Thanks,


#4

Did npm install pass successfully?


#5

yes, it did. i get success when finish run npm install. Could i run npm install again?


#6

hi @damencho
that is result when i re run npm install on my project: