[Bug] User ends up in limbo when disabling prejoin screen from prejoin screen

Just stumbled across this odd behaviour on my deployment, and can repro in meet.jit.si and alpha.jitsi.net

Steps to repro:

  1. On prejoin page, click settings
  2. Select “More” tab and uncheck “Enable pre meeting screen”
  3. Click “OK”

What happens:

Settings modal and prejoin screen dismissed prematurely, and it looks as though you have joined the meeting (filmstrip, toolbar, headings all visible) but not really – you don’t see anyone in the meeting, and nobody sees you. Toolbar buttons and video doesn’t work.

Only way to recover is to reload the page.

This is a very confusing behaviour for users and they could be hanging around for a while waiting for others to join.

What I expected:

Modal dismissed and still on prejoin page, and can join meeting as usual. No prejoin page on next visit unless re-enabled.


Is this a known issue? Should I raise issue on Github?

I’m able to reproduce this. Definitely not intended behavior. :thinking:

Yep, we will look at fixing it. Thanks for the report.

1 Like

Is this issue currently being worked on (perhaps indirectly)?

I’m asking just because I can repro the same issue on meet.jit.si, but it is “a little better” in beta.meet.jit.si.

So on beta:

  1. On prejoin page, click settings
  2. Select “More” tab and uncheck “Enable pre meeting screen”
  3. Click “OK”
    • everything works as expected :+1: (This used to send users into limbo.)
  4. Instead of joining, click settings again
  5. Select “More” tab and now check “Enable pre meeting screen”
  6. Click “OK”
    • User ends up in limbo once again :skull_and_crossbones:

Same issue on alpha.

1 Like

@shawn can you test on alpha.jitsi.net, seems it is fixed now. fix(prejoin) Consider user selection for prejoin visibility only on m… by horymury · Pull Request #10654 · jitsi/jitsi-meet · GitHub

Awesome! I can confirm that the issue is fixed in alpha. Thank you :bowing_man:

While testing this however, I observed something which I’m not sure is expected behaviour or not.

Repro:

  1. Join any room, and in settings disable prejoin page.

  2. Rejoin any room with url param override: #config.prejoinConfig.enabled=true

    • No prejoin page. Which means user settings takes precedence?
    • “Settings > More” looks as expected with pre-meeting option unchecked
      Curly_Curricula_Interfere_Fortunatelys___Jitsi_Meet
  3. Rejoin any room with url param override: #config.prejoinConfig.enabled=false

    • No prejoin as expected
    • pre-meeting option now missing from settings!
      Curly_Curricula_Interfere_Fortunatelys___Jitsi_Meet

Can repro in both alpha and meet.jit.si, so not a new behaviour.

Is this expected? i.e.

  • does user settings take precedence and cannot be overridden with url param?
  • do we expect URL param to affect visibility of option in settings?

@shawn both behaviors are expected. config.prejoinConfig.enabled acts as a switch on/off for the whole prejoin feature, so in case it’s off, existing user selection has no effect so we hide the setting completely. When on, the user see the prejoin screen by default but they have the option to hide it if they wish and we cannot force-show it through the iframe API. If it helps in any way, we preserve the user’s selection userSelectedSkipPrejoin in localStorage under the meeting’s domain.

1 Like

That makes perfect sense. Thank you.

And many thanks for all the great work you’re doing :bowing_man:

1 Like