Bug in new config parsing

We recreated our jicofo config based on the new config template. The xmpp client setting looks like this:

jicofo {
  xmpp {
    client {
      enabled = true
      hostname = "jabber.example.com"
      port = 5222
      domain = "example.com"
      username = "focus"
      password = "..."
    }
  }
}

makes jifoco try to connect to localhost:

Jicofo 2021-04-27 18:47:00.816 SEVERE: [14] [xmpp_connection=client] XmppProviderImpl.doConnect#225: Failed to connect/login: The following addresses failed: 'localhost:5222' failed because: localhost/127.0.0.1 exception: java.net.ConnectException: Connection refused (Connection refused)

‘hostname’ from the new config does not get used and seems to fall back to localhost. When setting JICOFO_HOST in the legacy config, connecting to the jabber server works. Maybe there is another place in the new config where we should put the hostname of the xmpp server. However, the default config template does not show any other place where to put it and we did not investigate src/main/kotlin/org/jitsi/jicofo/xmpp/XmppConfig.kt for another place.