Browser – iOS/Android connection visible but no audio and video

Thanks to the community for creating and maintaining Jitsi. Problem:

When I create a room, audio & video is only available between iOS and Android apps but not my browser (Firefox 78.0.2 on Mac OSX 10.11.6). The connection is there, the sound and image is not. Safari is not supported by meet.jit.si.

I cannot use only the mobile apps since I need to record the session (only available in
browser) and in any case meeting participants will use also browsers. Thanks for any help (people wanting to join the room in a few days)!

Have you tried the different permutations for starting the conference: start with browser, start with IOS, start with Android? Is the behavior the same in each case?

Are you using https://meet.jit.si? Do you get the same behavior with https://8x8.vc?

Thanks for your prompt reaction.

Yes: I have started session alternatively with Firefox (on OSX) and iOS. The devices recognise one another and the participants in the room but does not allow audio and video to pass. Camera and mic are allowed on OSX/browser and show no error. Icons on participants windows indicate whether mic & camera is on in the other device, regardless of the fact that there is neither signal. I can also chat between the participants/devices.

I have a number of add-ons on Firefox so as to increasing privacy. None is showing blocking meet.jit.si

Just tested 8x8.vc (browser – iOS app): identical situation.

Any additional instruction/suggestion/hint would be valuable!

You can toggle the setting for audio (press the ‘m’ key) and video (press the ‘v’ key). Is the problem that audio and video start ‘off’, but can be toggled to be on?

Do you see the same behavior with the Chromium, Chrome, ungoogled-chromium, or Iridium web browsers?

Thanks – and for indicating the shortcuts. Unfortunately, the result of using the shortcuts is naturally the same as when pressing the mic and camera icons on screen: no audio or video (but as mentioned, the users are visible and the chat works). But yes, these audio and video functions are familiar and the problem is not that simple.

I have not tried Chrome as, frankly, I want to stay at arms length from anything Google/Alphabet. I would like to avoid using Zoom with all its issues. The conference I am involved in would be a great opportunity to introduce Jitsi to an informed audience.

If you don’t like Google/Alphabet, then try the Iridium browser (https://iridiumbrowser.de/about) or ungoogled-chromium (https://github.com/Eloston/ungoogled-chromium): both take the privacy and borgesque “features” out of Chrome.

I run several events per month for non-technical users. For most users Jitsi works great, but I always seem to have one or two users that have issues.

I spoke to the Jitsi development team this morning: http://y2u.be/_76zvYbS7As

My takeaway is that the problems are usually machine and browser specific and so too hard to debug.

So the recommendation is to test with multiple machines and browsers.

If you have a reproducible issue, the Jitsi developers will fix it.

I cannot reproduce your issue, so we need to try different browsers and/or machines to isolate the issue. I suspect the browser, but you need to do the tests to narrow it down.

Just a brief note with my sincere thanks: the AV connection finally opened with the Iridium browser. You would know what a weight rolled off my shoulders! Thank you.
This solution was useful in many ways: apart from saving me in the conference, Iridium now allows me to have better work team meetings (not by mobile only) and it is a welcome option in the rare instances where Chrome features can be useful (although I will refrain from extensions).
Thanks also for sharing the dev team recording: interesting to hear how the brains behind this marvellous application go about developing it. Thanks a million again. —T.