Broken my jitsi installation while adding authentication

I did a vanilla installation of jitsi-meet on a new server with Debian Stretch. It worked!

However, I do need some authentication so I followed the simple instructions here:

But now it’s broken. I get “You have been disconnected. You may want to check your connection”. The Javascript console tells me:

2020-03-18T22:33:13.126Z [connection.js] <c.l>:  CONNECTION FAILED: connection.otherError
o @ Logger.js:154
Logger.js:154 2020-03-18T22:33:13.136Z [features/overlay] <Object.componentDidMount>:  The conference will be reloaded after 17 seconds.
Logger.js:154 2020-03-18T22:33:13.141Z [features/base/connection] connection.otherError
o @ Logger.js:154
Logger.js:154 2020-03-18T22:33:13.237Z [modules/RTC/RTCUtils.js] onUserMediaSuccess
Logger.js:154 2020-03-18T22:33:14.097Z [modules/UI/videolayout/SmallVideo.js] <g.w.updateView>:  Unable to init avatar - no id g
o @ Logger.js:154
DevTools failed to parse SourceMap: chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/sourcemaps/onloadwff.js.map
DevTools failed to parse SourceMap: chrome-extension://gighmmpiobklfepjocnamgkkbiglidom/include.preload.js.map
Logger.js:154 2020-03-18T22:33:14.500Z [features/base/storage] <Object.persistState>:  redux state persisted. 53bb95da47d716d3070f4e34bed63f9c -> 17fa5f248b9888d94dfd6f836e12b75a
DevTools failed to parse SourceMap: chrome-extension://gighmmpiobklfepjocnamgkkbiglidom/include.postload.js.map

I confess that most of that console info doesn’t mean much to me, but I’d be very grateful for any pointers you might be able to offer (and I appreciate that you must be rushed off your feet just now, with the entire world suddenly wanting videoconferencing – thank you for your time!)

I had broken mine as well, so welcome in the club :slight_smile:

My problem was similar to yours and maybe my hint applies.

I was mislead by number 3 in the instructions you cite and had placed

-Dorg.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com

respectively the corresponding version thereof into sip-communicator.properties where as it belonged into jicofo/config where I added it at the end of JAVA_SYS_PROPS. Watch out to get the quotes correct. I did not, which did not produce an error but had me hunt about my config for another 4 hours :wink:

However, since my base system was not a debian package but an AMI Linux, I am not sure if the hint should have applied. Anyhow, playing around and/or ignoring the Debian-related hints after a while brought me to a working configuration.

That third step isn’t completely clear to me – I don’t understand the first part, but it seems the second part is what actually applies to my case (“If you have Jicofo installed from the Debian package…”).

What I’ve actually done at that stage is to open the file /etc/jitsi/jicofo/sip-communicator.properties (which existed, but was empty), and I’ve added the line:
org.jitsi.jicofo.auth.URL=XMPP:video.mydomain.com

(Obviously I’ve got my actual domain name in place of “mydomain.com”.)

Still no sure where the problem is though. :-\

I skipped Step 5 of the instructions I mentioned because I’m not aware that I’m using jigasi – as I understand it, that’s only useful for people dialling in by phone, and I don’t need that.

However, that step would make use of the username/password that I’ve just created with prosodyctl and it occurs to me that I haven’t entered them in any config file anywhere. Um… Where should they go?

I checked my working reference configuration which claims to be a Debian 9 and is a Debian AMI image at Amazon.

In my configuration the /etc/jitsi/jicofo/sip-communicator.properties is empty. I added the
-Dorg.jitsi.jicofo.auth.URL=XMPP:video.mydomain.com
at the end of the config file in the same directory as part of JAVA_SYS_PROPS.

Ok. That’s not what the instructions said. :slight_smile: But the thing is working :stuck_out_tongue:

Another aspect could be the user name. I have in prosody/conf a video.mydomain.com.lua file with the line

admins = {“focus@auth.video.mydomain.com” }

and the user name I actually enter in jitsi-meet is focus@video.mydomain.com

I do not remember what name I used to register in prosodyctl. One of the two choices :stuck_out_tongue:

Hope this helps.

You should not use username focus for anything other than jocofo, that will lead to unpredicted problems.

Ah, I’ve solved the first part of the problem! Having followed the jicofo secure domain instructions to the letter, I kept getting “You have been disconnected” in the browser. The solution this was simply prosodyctl restart.