Breakout-rooms feature problem

Hello one and all.

Thanks for the great breakout-rooms feature! Just tried to enabling it, but there seem to be some issues on my setup. I can create breakout-rooms, but I cannot put users in it. The button “send to breakout-room” does not do anything it seems. Here my prosody config.

VirtualHost "meetings.domain.tld"
        authentication = "internal_plain"
        ssl = {
                key = "/etc/prosody/certs/meetings.domain.tld.key";
                certificate = "/etc/prosody/certs/meetings.domain.tld.crt";
        }
        speakerstats_component = "speakerstats.meetings.domain.tld"
        conference_duration_component = "conferenceduration.meetings.domain.tld"
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
            "speakerstats";
            "turncredentials";
            "conference_duration";
	    "muc_lobby_rooms"; 
            "muc_breakout_rooms";
        }
        c2s_require_encryption = false
        lobby_muc = "lobby.meetings.domain.tld"
        main_muc = "conference.meetings.domain.tld"
        muc_lobby_whitelist = { "recorder.meetings.domain.tld" }
	breakout_rooms_muc = "breakout.meetings.domain.tld"

Component "breakout.meetings.domain.tld" "muc"
    restrict_room_creation = true
    storage = "memory"
    admins = { "focus@auth.meetings.domain.tld", "jvb@auth.meetings.domain.tld" }
    muc_room_locking = false
    muc_room_default_public_jids = true

Component "lobby.meetings.domain.tld" "muc"  
    storage = "memory"  
    restrict_room_creation = true  
    admins = { "focus@auth.meetings.domain.tld", "jvb@auth.meetings.domain.tld" }
    muc_room_locking = false  
    muc_room_default_public_jids = true

VirtualHost "guest.meetings.domain.tld"
    authentication = "anonymous"
    c2s_require_encryption = false

Component "conference.meetings.domain.tld" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "token_verification";
    }
    admins = { "focus@auth.meetings.domain.tld" }
    muc_room_locking = false
    muc_room_default_public_jids = true

Someone has an idea how to fix this?

cheers, t.

I just updated mine and I don’t see any option for breakout rooms. My prosody config also doesn’t have the breakout room muc. Where did you get this muc from?

no, this seems to work fine on latest unstable, but as the only difference with current stable is 2 translations fixes, this can’t be the reason. Prosody config differs on 2 points:

    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        --"token_verification";
    }

and jvb is not part of the authorized admins.
You can always try to adapt, but I don’t see an obvious link with your problem.
Maybe it’s a browser bug. I use Chrome 96 for my tests, I just gave a try to 98 and there is no difference, this particular feature works for both 96 and 98. No warranty from me about 97 though.

Strange. I added those two modules and now I can join the breakout_rooms as moderator. Sending other participants to that room still does not work. Firefox 95 and Chromium 96.

In /usr/share/jitsi-meet/prosody-plugins/mod_muc_breakout_rooms.lua the settings says:

main_muc = "muc.jitmeet.example.com"

It’s conference.domain.tld on my setup. Could that be a problem maybe?

Yes. Should be your Jitsi FQDN after “muc.”

If I change that to muc.fqdn… I cannot create breakout_rooms anymore. I must have mixed up the settings somewhere I suppose.

Noooo, you don’t make that change in mod_muc_breakout_rooms.lua, you make it in your prosody config.

VirtualHost "jitmeet.example.com"
     modules_enabled = {
        "muc_breakout_rooms"
     }
     breakout_rooms_muc = "breakout.jitmeet.example.com"
     main_muc = "muc.jitmeet.example.com"

 Component "breakout.jitmeet.example.com" "muc"
    restrict_room_creation = true
     storage = "memory"
     admins = { "focusUser@auth.jitmeet.example.com" }
     muc_room_locking = false
     muc_room_default_public_jids = true

Wherever you see jitmeet.example.com, replace with your FQDN

Yeah, sorry if I was not clear. I configured my domain setting in /etc/prosody. But the problem remains. Can you post your main virtual host and breakout and conference component?

The ‘main_muc’ setting under the host can’t be at the same time ‘conference’ (for lobby) and ‘muc’ (for breakout rooms)

head mod_muc_lobby_rooms.lua
-- This module added under the main virtual host domain
-- It needs a lobby muc component
--
-- VirtualHost "jitmeet.example.com"
-- modules_enabled = {
--     "muc_lobby_rooms"
-- }
-- lobby_muc = "lobby.jitmeet.example.com"
-- main_muc = "conference.jitmeet.example.com"
--
gp@jitsitest:/usr/share/jitsi-meet/prosody-plugins$ head mod_muc_breakout_rooms.lua
-- This module is added under the main virtual host domain
-- It needs a breakout rooms muc component
--
-- VirtualHost "jitmeet.example.com"
--     modules_enabled = {
--         "muc_breakout_rooms"
--     }
--     breakout_rooms_muc = "breakout.jitmeet.example.com"
--     main_muc = "muc.jitmeet.example.com"
--

I’d say that it a doc bungling and it don’t matter which it is called. It’s still called conference on my setup.
Edit: it may not matter, but there is more to it than simply calling it ‘muc’. Code refers to a parameter called ‘muc_mapper_domain_prefix’ that seems to have as default value ‘conference’ so it’s probable than to call this particular component something other than ‘conference’ much care should be applied.

You don’t have a conference component setting?

So it’s possible lobby and breakout_room can not work at the same time?

They do.

I’m confused now. :slight_smile: Should I name the main_muc muc… or conference…?

keep it at conference.

Ok. Thanks. Let’s see if I can find the problem. Currently I can create breakout_rooms and enter them as moderator. Sending other participants to the breakout_room does not work.

I just tested this and stable seems to work. When I updated it from the old version it didn’t apply the settings for the breakout rooms. If you go to /usr/share/jitsi-meet/prosody-plugins/mod_muc_breakout_rooms.lua you will see at the top what needs to be added in. Once you have changed it to your domain it should work.

I did a fresh install and it works out of the box.

can they actually enter by themselves ?
and also when you say does not work, what happens exactly ? Does the action have any effect ? or is there no reaction in the UI ?

Same problem here with chrome 96. I can create breakout room but i can’t send participants to the created breakout room just created.

On my site there is an example-template available at:
/usr/share/jitsi-meet-prosody/prosody.cfg.lua-jvb.example