brandingDataUrl not working

Hi there,

I’m trying to use the dynamic branding feature via config option brandingDataUrl (PR). However, that URL is never called, not by the server nor the client; and thus branding does not work.

I couldn’t find any documentation about this feature and what requirements need to be fulfilled. I just set the option in config.js, but this is obviously not enough.

My server is a Debian buster with the current packages from jitsi.org.

Any help, howto, documentation is appreciated.

Thanks,
Reklov

1 Like

I have the same question, and not able to figure out how it works.

My installation followed the quick-installation guide on Debian. In the file /etc/jitsi/meet/meet.my-site.com-config.js:

    brandingDataUrl: 'https://meet.my-site.com/branding',

The URL https://meet.my-site.com/branding returns something like below:

    {
            backgroundImageUrl: 'xxxx',
            logoImageUrl: 'yyyy'
    }

The URLs above are all valid.

However I don’t see any change in the home page as well as when in a meeting.

Did you ever get it to work @Reklov or @goldyliang ? Would appreciate if you shared the answer

Alas, no, @Ahmed_Saleh; however I did not try any more, as I have no new information.

My current approach is to override interface_config.js (copy under /etc with alias in webserver config) setting image and backgroundcolor.

Thanks for the response @Reklov . Setting a static image is easy enough, it’s making it dynamic that’s the issue. I’ve seen it done in some instances on the web, just haven’t figured it out myself :confused:

this feature has been removed because 8x8 (the Jitsi sponsor) and the Jitsi project don’t like people using Jitsi (and 8x8) bandwidth without promoting their services. It’s against the meet.jit.si terms of service.

thanks for the info @gpatel-fr. I did not know that. Interesting. I figured since it’s open-source, you could still do that. Apparently not.

open source is not free bandwidth.
Edit: you can customize your own instance, where you install the open source software on resources that you are paying for.

Edit: you can customize your own instance, where you install the open source software on resources that you are paying for.

Exactly that was my goal. It would have been easier to do the customization with this feature. However, I can understand the reasoning behind it.
It would be nice though if the deactivation of this feature was (non-overridable) configurable.

Thanks for the clarification, @gpatel-fr

Fair enough.

Not sure I understand the outcome of this discussion. I’m grateful for clarification.

Configuration options for setting background and logo on a self hosted instance seem to be implemented but can’t be used?

There are related issues (one, two) and discussions (one, two) so it seems there is interest in such a feature.

Thanks,
hex