Blank page after updating libs in the server

Hi All,
I have cloned the latest jitsi-meet and built everything using:
rm -rf node_modules
npm install
make

However, after I uploaded the libs folder to the server under usr/share/jitsi-meet, I got blank grey page which used to be the welcome page. (I also reinstalled the latest jitsi-meet on the debian server).
I did’t get any errors in the Chrome console…

Also, when I was doing “npm install”, I got errors saying the size of lib-jitsi-meet.min.js exceeds 750KB, so I also cloned the lasted lib-jitsi-meet and disabled the webpack performance checking.

Maybe it is because of the new lobby feature? I did not have a SSL certificate for the raw ip address.

Can someone help me identify the issue?
Thanks

from what you say, before installing your home cooked version you did unrelated changes to your setup. Don’t do that. Get an up-to-date, standard version and get it to work without any custom code. Test your custom code against the working install using webpack server. Then if it works, install your custom code on the server.

Hi, thanks for replying.

Yes, I followed the advice and

  1. purged the original jitsi-meet on the server and followed the instruction to get the latest version installed. Opened the url, everything worked.
  2. cloned the latest jitsi-meet repo, did npm install and make, and replaced the libs folder on the server with the one just built.
  3. got blank page…

Weird enough, I happened to have an old libs folder, and If I replace the one on the server with this old version, it works…

Any thoughts on that? Thanks

Well, my advice was to test the generated libraries with webpack first.

Hi,sorry I misinterpreted that.
So I tried ‘npm install’ and ‘make dev’, and I got ‘Error: ENOSPC: System limit for number of file watchers reached’, after searching online, I solved the error by changing the file watchers limit: ‘echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p’.
It compiled with warnings.
However, my ‘https://localhost:8080/’ showed me ‘ERR_CONNECTION_REFUSED’

I did get the latest repo for jitsi-meet…did nothing but ‘npm install’ and ‘make dev’

Did I do something wrong?
Thanks

to be candid, I never follow the official procedure so I have no idea why make dev does not work for you - did you wait enough for the server to be online ?
What I do is:

make

export WEBPACK_DEV_SERVER_PROXY_TARGET=https://yourserver.yourtld

./node_modules/.bin/webpack-dev-server -d

if proxy target (yourserver.youtrd in the above example) is not specified, the default value is alpha.jitsi.net

Hi sorry I was running the compilation on a VM on cloud…sorry for wasting your time because of my stupidness. Local development using webpack did work using the default alpha.jitsi.net proxy target.

Does this suggest that the compiled ‘libs’ folder actually worked? So there must something wrong with my server config which caused problem rendering the ‘libs’, right?

Thanks for the help

Well, nothing wrong with that, connect to your VM with SSH forwarding the port
LocalForward 8081 localhost:8080

then with your browser go to https://localhost:8081

you may have to tinker a bit with your web server if you have a SAMEORIGIN protection, but it should work.

This said, generally it’s bad to do dev on a production server.

once your libs work with the webpack server, goto your server, save the content of /usr/share/jitsi-meet/libs directory, then copy your files in it, ensure the same rights are set as for the saved files, it should work. Restarting the web server could help.

Hi,
Thanks for the advice. I am experiencing really weird behaviors when deploying it locally(sometimes it works, sometimes it doesn’t)… However, that is not a problem for now, and I can solve it later.

For restarting the web server, all I need to restart are nginx,jitsi-videobrdige2,jicofo and prosody, right?

Thanks.

nginx. I’m not even sure that it’s necessary, maybe all that is neded is to empty browser cache;

Interesting…
However, I am not sure why the compile libs is not working on local dev or on the actual server…
I just reset everything to the latest jitsi-meet, ‘npm install’ and ‘make’…and the compiled libs is just not working… :frowning:

Anyway, thanks for the help! I will try it later

I am so sorry…I was so stupid…
I didn;t install the latest version of jvb,jicofo, prosody on the server…
now problem solved…
Sorry for wasting your time…

Best.