Blank Page after installing on own Domain (localhost, dyndns und NAS)

After Installing Jitsi-Meet and the other Packets.
I try to open the index.html from localhost and from my Domain (jpruehmann.dnshome.de) via https:// but only get an Blank Page.
How can I at least get the Start Page?

Thanks,

Welcome to the forum.

How did you install? What guide did you use?
My suspicion is you have an error in your config.js (likely an extra or missing character somewhere).

I installed via Synaptic,
I´ve used the Documentation for local install on the Homepage.
I did not change anything since I don´t know what.

hum, for home users it’s necessary to ask a trivial question first: do you have adequate bandwidth to run a video server: for even very small meetings (4-5) you will need at least 10 mbits/s upload. If you have only Adsl forget it, fiber connection is necessary.
If this precondition is fulfilled, can you show the web server configuration ?

<VirtualHost _default_:443>
        ServerName jpruehmann.dnshome.de
        ServerAdmin jan-peter@ruehmann.name
        DocumentRoot /var/www/html/jitsi-meet
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
     SSLEngine on
     SSLProtocol all -SSLv2 -SSLv3
     SSLCertificateFile /etc/letsencrypt/live/jpruehmann.dnshome.de/cert.pem
     SSLCertificateKeyFile /etc/letsencrypt/live/jpruehmann.dnshome.de/privkey.pem
     SSLCertificateChainFile /etc/letsencrypt/live/jpruehmann.dnshome.de/chain.pem
    <FilesMatch "\.(cgi|shtml|phtml|php)$">
      SSLOptions +StdEnvVars
    </FilesMatch>
    <Directory /var/www/html/jitsi-meet>
            SSLOptions +StdEnvVars
            Options Indexes FollowSymLinks
            AllowOverride All
            Require all granted
    </Directory>
</VirtualHost>

I have no experience with Apache, but did you take a look at the Nginx configuration ? you are missing quite a lot of stuff, serving Jitsi is not just serving a bunch of files straight from the disk.

    location = /config.js {
        alias /etc/jitsi/meet/meet.example.com-config.js;
    }

    location = /external_api.js {
        alias /usr/share/jitsi-meet/libs/external_api.min.js;
    }

     #ensure all static content can always be found first
    location ~ ^/(libs|css|static|images|fonts|lang|sounds|connection_optimization|.well-known)/(.*)$
    {
        alias /usr/share/jitsi-meet/$1/$2;
    }

    # BOSH
    location = /http-bind {
        proxy_pass      http://localhost:5280/http-bind;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $http_host;
    }

I have just taken a look at the Jitsi handbook and oddly it seems to ignore the config.js, unless I missed it. But it’s definitely needed. Oh well there is even an apache example.

And I have no experience in NGINX will look into the Apache example again tomorrow.
Had tried to enable the include, proxy http and proxy html Modules but then Apache had failed at restart.

Have build a Configuration from the example and the for other websites working vhost conf.
It is accepted by apache2 but I still only get an Blank Page.

<VirtualHost _default_:443>
        ServerName jpruehmann.dnshome.de
        ServerAdmin jan-peter@ruehmann.name
        Protocols h2 http/1.1
        DocumentRoot /var/www/html/jitsi-meet
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
        SSLEngine on
        SSLProtocol             all -SSLv2 -SSLv3 -TLSv1 -TLSv1.1
        SSLCipherSuite          ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384
        SSLHonorCipherOrder     off
        SSLSessionTickets       off
        SSLCertificateFile /etc/letsencrypt/live/jpruehmann.dnshome.de/cert.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/jpruehmann.dnshome.de/privkey.pem
        SSLCertificateChainFile /etc/letsencrypt/live/jpruehmann.dnshome.de/chain.pem
        Header always set Strict-Transport-Security "max-age=63072000"
    <FilesMatch "\.(cgi|shtml|phtml|php)$">
        SSLOptions +StrictRequire
    </FilesMatch>
    <Directory /var/www/html/jitsi-meet>
        SSLOptions +StrictRequire
        Options Indexes MultiViews Includes FollowSymLinks
        AllowOverride All
        Require all granted
        AddOutputFilter Includes html
    </Directory>
        ErrorDocument 404 /static/404.html
        Alias "/config.js" "/etc/jitsi/meet/jitsi-meet.jpruehmann.dnshome.de-config.js"
    <Location /config.js>
        Require all granted
    </Location>
        Alias "/external_api.js" "/usr/share/jitsi-meet/libs/external_api.min.js"
    <Location /external_api.js>
        Require all granted
    </Location>
        ProxyPreserveHost on
        ProxyPass /http-bind http://localhost:5280/http-bind/
        ProxyPassReverse /http-bind http://localhost:5280/http-bind/
        RewriteEngine on
        RewriteRule ^/([a-zA-Z0-9]+)$ /index.html
</VirtualHost>

The Site is up now.
But I can´t start a conversation.
It only says that there is someting wron that it is trying to resolve and that is reconnecting in a short time.
Thanks.

I´ve changed that in the VHost config.

 Alias "/config.js" "/etc/jitsi/meet/jpruehmann.dnshome.de.js"
    <Location /config.js>
        Require all granted
    </Location>
        Alias "/external_api.js" "/libs/external_api.min.js"
    <Location /external_api.js>