Black video, no audio with Firefox


#1

Hi,

I’m new to jitsi-meet and I’ve followed the quick install guide to set up an instance on a virtual machine. During setup I’ve provided the IP adress. Clients can connect to it, and it works fine but only if they use Chrome/Chromium. With Firefox (tested from 60 to 62), they only get a black screen, no video, no audio.

OS is debian 9 up-to-date. No firewall, no NAT.

ii  jitsi-meet                     1.0.3229-1                     all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody             1.0.2942-1                     all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-web                 1.0.2942-1                     all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config          1.0.2942-1                     all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge              1077-1                         amd64        WebRTC compatible Selective Forwarding Unit (SFU)

Is there something I missed ? Or something specific to configure jitsi-meet to make it works with Firefox ?

On the server logs I can’t find anything, except this:

JVB 2018-09-12 14:51:04.549 SEVERE: [11922] org.ice4j.socket.MergingDatagramSocket.log() Cannot find socket to remove.
JVB 2018-09-12 14:51:04.551 SEVERE: [11929] org.ice4j.socket.MergingDatagramSocket.log() Cannot find socket to remove.
JVB 2018-09-12 14:51:04.554 SEVERE: [11899] org.ice4j.socket.MergingDatagramSocket.log() Cannot find socket to remove.

On Firefox logs:

onaddstream is deprecated! Use peerConnection.ontrack instead.
[modules/RTC/TraceablePeerConnection.js] <a>: createAnswerOnError Error: “An unmapped SSRC was found.”

Not sure it’s relevant.

With default jitsi-meet config file, Firefox also complains that it can’t access the MIC. If I set “enableFirefoxSimulcast” to true, no more error, but same result (black video, no audio).

In documentation, forums, lot of people suggest to use Chrome/Chromium. So is Firefox supported by jitsi-meet ?

Any help will be greatly appreciated. Thank you

Best regards,
Edouard


#2

Are you testing with 2 or 3 participants?
Do you repro this on meet.jit.si?


#3

We mostly tried with only 2 participants.

Does meet.jit.si works for compony environments ? We access Internet thru a web proxy, behind of firewall. Nothing unusual but not sure UDP will pass thru etc. Only HTTP/HTTPS.

I’ve just tried at home and it seems that meet.jit.si supports Firefox. So what’s wrong with our instance ? Is something missing in the quick install guide ?


#4

So we try on meet.jit.si and can reproduce. But sightly different, jitsi saying that other participant has network connectivity problems. Could that be because port 10000 is blocked on the proxy ? Because it’s working at my home without a proxy.

So if you have any suggestions on why meet.jit.si works with firefox but don’t when you follow the quick install guide, I would be very interested.


#5

meet.jit.si has also turn servers, which can be used and for p2p and for the bridge connection. Those turn servers can be used with tcp port 443, so I suspect that is the reason of the difference.


#6

Thank you I will try to set a turn server and add its address in our jitsi-meet config.


#7

#8
Unfortunately, a direct connection is not always possible between the participants. In those cases you can use a TURN server to relay the traffic

Do you know in which cases a direct connection is not possible ? Because our jitsi-server and clients are on the very same LAN. No firewall. No NAT.


#9

Well if clients are in the same network and jvb advertises its internal and external address the clients should be connecting using the internal address. So if it is p2p or jvb they should be using the local network.
Firefox p2p is disabled by default, I think.

Are you all the time testing with this enabled?
I think this is not well tested and still experimental, maybe the last time when we were working on that there were some FF bugs for which status I’m also not sure. So you should not enable that.


#10

Yes I’m always testing with enableFirefoxSimulcast, but I will go back on this parameter.
On this instance, chromium is working fine. So do I really need a Turn server ? If it’s quick to install I could try tho.

We also have an old instance of jitsi, and this one is working fine with Firefox AND chromium. Is there a way I can guess/tell the version of jitsi from the web interface ? I can’t access this old instance with SSH.


#11

Turn server is needed for some very restricted nats, where udp is disabled and only https on port 443 is alloy.

The version you can guess by opening source of index page and che ?v= param for appbundle file. But this the version of jitsi-meet-web package, not jitsi-meet package.