Black screen for more than two people at a time

Thanks so much!

I ran the ifconfig and this is what I get. I do know that my public IP is: 13.92.244.211…Just not sure what the local IP would be

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be REMOVED:
vsftpd*
0 upgraded, 0 newly installed, 1 to remove and 6 not upgraded.
After this operation, 334 kB disk space will be freed.
Do you want to continue? [Y/n] yes
(Reading database … 60414 files and directories currently installed.)
Removing vsftpd (3.0.3-9build1) …
Processing triggers for man-db (2.8.3-2ubuntu0.1) …
(Reading database … 60362 files and directories currently installed.)
Purging configuration files for vsftpd (3.0.3-9build1) …
Processing triggers for ureadahead (0.100.0-21) …
Processing triggers for systemd (237-3ubuntu10.24) …
root@Video:~# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.0.1.4 netmask 255.255.255.0 broadcast 10.0.1.255
inet6 fe80::20d:3aff:fe14:85c8 prefixlen 64 scopeid 0x20
ether 00:0d:3a:14:85:c8 txqueuelen 1000 (Ethernet)
RX packets 390238 bytes 177228415 (177.2 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 434150 bytes 99361819 (99.3 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 154901 bytes 32094691 (32.0 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 154901 bytes 32094691 (32.0 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

it’s there, your local IP is 10.0.1.4

so make it
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=10.0.1.4
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=13.92.244.211
and restart JVB
/etc/init.d/jitsi-videobridge restart

I will try this

Greatly appreciate the help! It works!

We would like to make this private and I am wondering if you could help us with that - also we would like to add our logo

I‘m still stuck here. My machine is aws ec2, system is ubuntu 18.04, “ifconfig” shows:

br-0b9bfdcf6e3c: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 172.18.0.1 netmask 255.255.0.0 broadcast 172.18.255.255
inet6 fe80::42:2ff:feac:5fb8 prefixlen 64 scopeid 0x20
ether 02:42:02:ac:5f:b8 txqueuelen 0 (Ethernet)
RX packets 581806 bytes 6905642697 (6.9 GB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 506907 bytes 270579221 (270.5 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

docker0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 172.17.0.1 netmask 255.255.0.0 broadcast 0.0.0.0
inet6 fe80::42:23ff:febf:342d prefixlen 64 scopeid 0x20
ether 02:42:23:bf:34:2d txqueuelen 0 (Ethernet)
RX packets 4726811 bytes 515799293 (515.7 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 11585220 bytes 27779851214 (27.7 GB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 9001
inet 172.31.40.36 netmask 255.255.240.0 broadcast 172.31.47.255
inet6 fe80::4a0:dff:fed0:d6f6 prefixlen 64 scopeid 0x20
ether 06:a0:0d:d0:d6:f6 txqueuelen 1000 (Ethernet)
RX packets 25902458 bytes 34341880720 (34.3 GB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 9303503 bytes 9433390114 (9.4 GB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 1623070 bytes 6339378608 (6.3 GB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1623070 bytes 6339378608 (6.3 GB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

“netstat -apn | grep 4443” shows:

tcp6 0 0 172.31.40.36:4443 :::* LISTEN 8742/java

I don’t know why run jvb.sh it will use 172.31.40.36 to listen port. I found this construct of project:

                   +                           +
                   |                           |
                   |                           |
                   v                           |
                  443                          |
               +-------+                       |
               |       |                       |
               | NginX |                       |
               |       |                       |
               +--+-+--+                       |
                  | |                          |
+------------+    | |    +--------------+      |
|            |    | |    |              |      |
| jitsi-meet +<---+ +--->+ prosody/xmpp |      |
|            |files 5280 |              |      |
+------------+           +--------------+      v
                     5222,5347^    ^5347      4443
                +--------+    |    |    +-------------+
                |        |    |    |    |             |
                | jicofo +----^    ^----+ videobridge |
                |        |              |             |
                +--------+              +-------------+

It seems that client will connect tcp/4443 on server directly, I’m already allow tcp/4443 to be visit thought firewall. And I’m also config local_address in /etc/jitsi/videobridge/sip-communicator.properties:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=172.31.40.36
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=18.179.14.10

But it doesn’t work. I’m not sure jvb.sh will use config with path “/etc/jitsi/videobridge/sip-communicator.properties” or “~/.sip-communicator/sip-communicator.properties”.

I’m try to forward port 4443 to 172.31.40.36:4443 in file /etc/ufw/before.rules:

*nat
:PREROUTING ACCEPT [0:0]
-A PREROUTING -i eth0 -d 18.179.14.10 -p tcp --dport 4443 -j DNAT --to-destination 172.31.40.36:4443
-A POSTROUTING -s 192.168.1.0/24 ! -d 192.168.1.0/24 -j MASQUERADE
COMMIT

And now I can telnet the port from my local machine successfully:
telnet 18.179.14.10 4443

But jvb works for a while only, jvb log shows:

org.jitsi.impl.neomedia.RTPConnectorOutputStream.log() Failed to send a packet to target /182.138.150.37:49724:java.io.IOException: No active socket

@David_Smilence
For AWS you don’t need to do anything on the VM, just make sure iptables are off and you have the correct addresses in jvb config. Then you just need to open those ports in the Security Group of the EC2 instance (this is creating the forwarding for you on aws level).

Thank you, I disabled firewall, now jvb works, I’ll test and watch its stability.

I have the same problem and none of the above mentioned solutions seems to work for me…
I am using the docker containers from docker-jitsi-meet and willing to be hosting this in a local network, so not behind NAT, only p2p connection between two clients seems to be working, with more clients Audio and Video disconnect, messaging keeps working though.
I have set the DOCKER_HOST_ADDRESS in the .env file.
chrome://webrtc-internals shows this in the setRemoteDescription tab after connecting from the third device:

So I removed all docker containers and reran docker-compose with the exact same .env and docker-compose.yml files. I have absolutely no idea what the problem was, but now everything is working fine.

Thanks very much @damencho you made my day :slight_smile:

Sharing my experience from a very restrictive LAN network.

Below a working JTSI server with three people (and more) under a NAT router,

  • Ubuntu Server 16.04 (yes, still works fine),
  • external letsencypt domain (my own cert and key files),
  • Apache 2.4,
  • last jitsi-meet_2.0.5142-1_all.deb (14-Oct-2020 16:26).

1/ First, make a clean full install - steps by steps - from handbook :

2/ Testing ports forwarding :

=> You needs to stop JVB2 :

sudo service jitsi-videobridge2 stop

=> You need a client to sending packets (from another computer or a VM, for exemple).
=> You need your working JITSI server to receive testing packets.

Testing your 4443 TCP port and 10000 UDP port.
Or, your external TCP/UDP ports opened in your LAN network.
In my server LAN, we can only have these TCP/UDP externals ports opened :
80, 443, 21, 22, 9050 to 9080 (9050:9080)

So, i change for JITSI :
=> 10000 udp port to 9050
=> 4443 tcp port to 9051

Take a while for reading the BBB manual and testing your opened ports with “netcat” commnand tool.
Read carrefuly BBB handbook and change the correct port if needed (jitsi default 4443TCP and 10000/UDP) :

UNDER JITSI SERVER YOU MUST RECEIVE MESSAGE FROM CLIENT

3/ Updating your firewall rules

So i need to open 9050 UDP and 9051 TCP ports.
Change the ports numbers if they are opened from the netcat previous step :

sudo ufw allow 9050/udp
sudo ufw allow 9051/tcp

4/ Append in :

/etc/jitsi/videobridge/sip-communicator.properties

#opened UDP port identified by netnat :
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=9050
#opened TCP port identified by netnat :
org.jitsi.videobridge.TCP_HARVESTER_PORT=9051
#Optional :
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true

#internal IP V4 inet adress from command : ifconfig
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=xxx.xxx.xxx.xxx
#Your external IP over the WAN, the same in : /etc/hosts
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=xxx.xxx.xxx.xxx

Comment the line -> STUN (turn server is not needed) :

#org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443

5/ Restart JVB2 :

sudo service jitsi-videobridge2 start

Testing from Web client …

Hi, the same problem here :(.
I have installed jtsi on docker.
Works great with two users but when add new user, all partecipants turn black.
I have checked org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES and the setting seems ok.

Any solution?

Thanks!