basexx error in Jitsi-meet-tokens install

Hello,
I am getting an error that is preventing me to fully install Jitsi-meet-tokens. I have spent a lot of time and read all the post and havent been able to find a solution.

I get a bassex error regarding the tls certificate. I could not install this dependency manually.

This is my history

1 sudo hostnamectl set-hostname jitsimeet
2 sudo sed -i ‘s/^127.0.1.1.*/127.0.1.1 vc2zencast.v jitsimeet/g' /etc/hosts 3 sudo hostnamectl set-hostname jitsimeet 4 sudo sed -i 's/^127.0.1.1.*/127.0.1.1 vc2zencasttv jitsimeet/g’ /etc/hosts
5 hostname
6 hostname -f
7 sudo ufw allow OpenSSH
8 sudo ufw allow http
9 sudo ufw allow https
10 sudo ufw allow in 10000:20000/udp
11 sudo ufw enable
12 sudo apt update
13 sudo apt upgrade -y
14 sudo apt install -y openjdk-8-jre-headless
15 echo “JAVA_HOME=$(readlink -f /usr/bin/java | sed “s:bin/java::”)” | sudo tee -a /etc/profile
16 source /etc/profile
17 sudo apt install -y nginx
18 sudo systemctl start nginx.service
19 sudo systemctl enable nginx.service
20 cd
21 wget -qO - ttps://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
22 sudo sh -c “echo ‘deb ttps://download.jitsi.org stable/’ > /etc/apt/sources.list.d/jitsi-stable.list”
23 sudo apt update -y
24 sudo apt install -y jitsi-meet
25 sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh
26 sudo wget ttps://packages.prosody.im/debian/pool/main/p/prosody-trunk/prosody-trunk_1nightly747-1~xenial_amd64.deb
27 sudo dpkg -i prosody-trunk_1nightly747-1~xenial_amd64.deb
28 lsb_release
29 sudo apt-get install jitsi-meet-tokens
Here I get the following error

Error: Error fetching file: Failed downloading ttps://github.com/aiq/basexx/archive/v0.4.1.tar.gz - tlsv1 alert protocol version
Failed to install basexx - try installing it manually
Processing triggers for libc-bin (2.23-0ubuntu11) …

I have tried to install it manually and i get the same error. How can I fix this?

This is my set up

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial

Thank you!

Try luarocks install basexx

1 Like

Hello, thenks for your reply! Nope, that doesn’t work

root@jitsimeet:~# luarocks install basexx
Installing https://rocks.moonscript.org/basexx-0.4.1-1.rockspec
Using https://rocks.moonscript.org/basexx-0.4.1-1.rockspec… switching to ‘build’ mode

Error: Error fetching file: Failed downloading https://github.com/aiq/basexx/archive/v0.4.1.tar.gz - tlsv1 alert protocol version

1 Like

basexx archive broken
manual install did not also solve the issue
Can you help us on installing jitsi token

1 Like

Same error as what ZenCast_TV got. Any updates? Can’t proceed with token authentication.

luarocks install basexx
Works, but then gives a new error:

module ‘luajwtjitsi’ not found:No LuaRocks module found for luajwtjitsi