Base Jitsi-Meet Drops video/audio when 3 or more people connect

Hello everyone,

This morning I realized there was an issue with my Jitsi meet program where it drops video and audio when a 3rd person connects to the room.

We have our own server set up and it did the same thing for my modified version so I downloaded the base Jitsi-meet, ran npm install, make and then started my server. It does the same thing. I’ve attached the google chrome output log in hopes that someone can help me figure out what’s going wrong.

I’ve been told that the appropriate ports were forwarded (443,4443, 10000).

If you need something else, please let me know and advise how i can get it. I’m still new to posting and debugging.

Thanks!
J

output.log (41.3 KB)

Hi,
i have the same problem. A third user connects and all crashes. All other user get kicked out and it’s over.

Do you use also the docker image?

Hi @CarlosP,

Our backend code was set up before I began my work on the project. I was only using the github.com/jitsi/jitsi-meet version.

Thanks
J

for extra information, this is my netstat -tulpn.
How do i get udp port 10,000 state to be set to LISTEN like the others? Is this the issue?


@damencho. do you know how to do this?

Adding more information:

I tried putting these lines in the jitsi/videobridge/sip-communicator.properties file:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

I also tried making a ~/.sip-communicator/sip-communicator.properties file and put them there too. Not fixed yet.

I saw this in the errors when the third person joins:


I use the Jitsi Quick Install Version

It’s the jvb log that you need to open, not the js log. The 10000 udp stuff is easy to debug, first setup jitsi to disable p2p to allow you to test with 2 computers (it’s more easy that way), then on the first station look at the trafic with tcpdump or wireshark on port 10000, does it start toward your server ? hopefully yes, then is there a reply ? if not (as likely given the symptoms) go to your server and use tcpdump or tshark to see if udp packets are received on port 10000. If no packets are received while they are starting from your station (remember these packets don’t flow when your computer is the only one connected) then you are almost there, you have to find where the packets are blocked.

I found these if it helps:
Console Errors:

  • 2020-05-04T19:48:37.386Z [modules/RTC/BridgeChannel.js] <e.value>: Bridge Channel send: no opened channel.

  • 2020-05-04T20:06:54.564Z [JitsiConference.js] <e.sendMessage>: Failed to send E2E ping request or response. undefined

  • 2020-05-04T20:07:25.977Z [modules/xmpp/JingleSessionPC.js] ICE connection state: failed

Jicofo Log:

  • WARNING: [12] org.jitsi.jicofo.FocusManager.log() No dedicated JVB MUC XMPP connection configured $

  • SEVERE: [46] org.jitsi.jicofo.bridge.JvbDoctor.log() Unexpected error returned by the bridge: jvbb

  • WARNING: [30] org.jitsi.jicofo.bridge.BridgeSelector.log() No pub-sub node mapped for jvbbrewery@i

  • SEVERE: [46] org.jitsi.jicofo.AbstractChannelAllocator.log() Failed to allocate channels, will con$

org.jitsi.protocol.xmpp.colibri.exception.ColibriException: XMPP error: <iq to='focus@auth.video.m-healthsolutions.com/focus15559$

JVB log:

  • WARNING: [29] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connecti$

org.jivesoftware.smack.XMPPException$StreamErrorException: system-shutdown You can read more about the meaning of this stream err$

stream:errorReceived SIGTERM</stream:error>

  • WARNING: [29] [hostname=localhost id=shard] MucClient$1.connectionClosedOnError#295: Closed on error:

org.jivesoftware.smack.XMPPException$StreamErrorException: system-shutdown You can read more about the meaning of this stream err$

stream:errorReceived SIGTERM</stream:error>

  • WARNING: [21] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#643: [MucClient$

org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘localhost:5222’ failed because: local$

  • WARNING: [13] Videobridge.start#906: No authorized source regexp configured. Will accept requests from an$

Huh. All these errors, you sure you kept to the basic simple install and did not add some enhancements of your own ? I wonder if you are using jvb2, in this case I’d think there would be pairing errors in the jvb log if the main problem was the 10000 UDP (there could have been pairing errors in the jvb1 logs but I never noticed when I was still using it), there are possibly bigger problems. Did you consider setting up a VM and doing a fresh install ?

Hey there,

So i didn’t do the initial install and I’m afraid if i wipe it, i won’t be able to get it back running…
Here are some changes i made:

  • Simple UI modifications - it wouldn’t do 3-way calling even on base project
  • Added the org.ice4j.ice.harvest…public_address / local address lines to sip-comm.
  • Added a disable auto login line to the jicofo sip-comm
  • Added the Secure domain

I’m pretty sure I’m using jvb2, not 1. I can’t service jitsi-videobridge restart… has to be 2.

I tried setting up a fresh install of ubuntu 18.04 fresh install but got stuck at the certificate failed issue with http-01 challenge and couldn’t move forward.

the really silly part… I got the project working on my home server… but i can’t get it running on my work server which has all these issues.

Well, you have in your computer the full jicofo.log file without the data beyond 80 columns cut out so you can read yourself the actual error messages and solve your problem… Bye.

Sorry, here are the full logs. I didn’t know how to get them at first.
jicofo.txt (44.9 KB)
jvb.txt (10.1 KB)

@damencho can you assist?

The error you see XMPP error: <iq to='focus@auth.mydomain.com/focus1642318772068735' from='jvbbrewery@internal.auth.mydomain.com/883603e2-484c-4dcb-8fd0-62ee37bd7d70' id='wjmjS-120' type='error'><error type='auth'><not-authorized xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error></iq>

Has to do with 2020-05-06 10:51:09.807 INFO: [13] Videobridge.start#892: Authorized source regexp: focus@auth.mydomain.com/.*

Can you remove from your config org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP and try again?

Upgrading jvb should take care of this normally: https://github.com/jitsi/jitsi-videobridge/blob/master/debian/postinst#L106