Bad video quality and lags when using iOS app or browser


#1

We are experiencing strange differences in call quality when using the Jitsi Meet iOS app or a browser (FF or Chromium) compared to when using Jitsi from within RocketChat. Jitsi and RC are self hosted (Jitsi via quick install). When a room is opened from within RC on the desktop clients video quality is HD and there are no lags or connectivity issues. As soon one participant is connected via browser or app we see much lower video quality, lags, warning messages (connectivity issues, network error, reconnecting etc.). I think bandwidth problems can be ruled out as both parties are the exact same networks in both use cases.

I tried to modify several settings in our Jitsi installation to no avail. I’m lost here. Does anybody have an idea what is causing this or where to start troubleshooting?

Thanks for your help!


#2

Maybe on a related note (not sure though) when connected to a conference via FF, in the connection stats window the resolution is always shown as N/A for all participants.


#3

RC is built on Electron, so a more apples to apples comparison would be to use latest Chrome. On Firefox not all stats are supported so they show N/A, but that’s ok.

How many clients are connected when you conduct the tests? Check if the connection is P2P or not (in the signal bars menu for the local user). If not in P2P mode, the traffic will traverse the server so bandwidth problems are possible.

Also, since you are self-hosting, what kind of server are you using? (cores and RAM)


#4

I tested with 2 clients. I suppose the connection is P2P (not exactly sure how to verify though). Here are screenshots from the connection stats:

05

And the output of console that are related to P2P that I could find:

Server is a Hetzner Cloud Server (2 vCPU, 4GB RAM).

In this specific example bandwidth might play a role as both clients are on the same network that has rather mediocre connection speed but the phenomenon is also happening with remote connections via FF. Whereas the same connection via RC is pristine.


#5

Does anything change if you test with Chrome? You should see “p2p” like this:

16

Otherwise it means you are going through the server, where connection problems are possible.


#6

With Chrome “p2p” is shown as in your example. Interestingly Chrome connects via IPv4 address, while FF connects via IPv6!? Is there a recommendation regarding IPv4 vs IPv6 (or to block IPv6 traffic altogether)? Chrome connection looks much better from the video quality than FF.

As far as I understand there is no browser 100% supported by Jitsi if we want to get external clients (customers) into our company conference rooms without them having to install any extensions or apps. Chrome doesn’t support screensharing without extensions, FF quality is terrible, Safari (would be our top preference) is Audio only. Right?


#7

HI there,

Your setup is interesting. For some reason the P2P call didn’t succeed, and I suspect IPv6 is the culprit here. Blocking IPv6 on the FF machine should yield the same results as on Chrome.

Not quite. The FF issue seems to be related to your use of IPv6 which somehow prevented P2P from being used and thus you ran into bandwidth issues when your server was involved (but you mentioned this was possible because the network wasn’t very good, right?).

As for Chrome, starting with M72 (to be released in a week) removes the need for the extension. You’ll need to update to the latest stable Jitsi Meet for that to work. This new release will happen in the next couple of days.

Safari is audio-only for now, yes.


#8

Thx for clarifying things saghul. I’m looking forward to the upcoming updates to Jitsi Meet and Chrome, this should hopefully solve our problem. I do not have control over customers IPv6/IPv4 settings hence a solution that works independently is all the better.


#9

I disabled IPv6 on the machine but still couldn’t get FF to establish a P2P connection over IPv4. What could be the reason for that? I tried with all extensions disabled just to make sure they do not interfere somehow. Chrome, Chromium and even unsupported Opera (Chromium based) work just fine. Any ideas or hints where to start troubleshooting?


#10

iirc we don’t support p2p with ff, but that may have changed sine last I checked