Auto disconnects in meet hosted in VPS server with 1+ people in meet

Condition: When two users connects the meeting says unfortunately some problem occurred and process to rejoin.

1 . My Server is hosted at VPS server, so is it behind NAT so that i can use the methods said on behind NAT ?
Note: I will be having same public IP and local IP for the case, which is weird.

Any luck. Searched and tried everything in the community still no luck. :frowning:

Error in chrome console :

Logger.js:154 2020-06-05T21:50:08.304Z [modules/UI/videolayout/SmallVideo.js] <v.remove>: Remove thumbnail 0836d61c

Logger.js:154 2020-06-05T21:50:08.314Z [conference.js] <ee._onConferenceFailed>: CONFERENCE FAILED: conference.iceFailed

Logger.js:154 2020-06-05T21:50:08.337Z [modules/UI/videolayout/SmallVideo.js] <g.remove>: Remove thumbnail 654ebc67

Logger.js:154 2020-06-05T21:50:08.346Z [modules/rttmonitor/rttmonitor.js] <h.stop>: Stopping RttMonitor.

Logger.js:154 2020-06-05T21:50:08.348Z [modules/e2eping/e2eping.js] <h.stop>: Stopping e2eping

Logger.js:154 2020-06-05T21:50:08.356Z [modules/xmpp/ChatRoom.js] <_.doLeave>: do leave a@conference.mely.com.np/654ebc67

Logger.js:154 2020-06-05T21:50:08.443Z [modules/UI/videolayout/VideoLayout.js] <Object.removeParticipantContainer>: No remote video for 0836d61c

Logger.js:154 2020-06-05T21:50:08.446Z [conference.js] <a.<anonymous>>: USER 0836d61c LEFT:

1. u {_jid: "a@conference.mely.com.np/0836d61c", _id: "0836d61c", _conference: se, _displayName: undefined, _supportsDTMF: false, …}

Logger.js:154 2020-06-05T21:50:08.450Z [modules/xmpp/moderator.js] <u.onMucMemberLeft>: Someone left is it focus ? a@conference.mely.com.np/0836d61c

Logger.js:154 2020-06-05T21:50:08.452Z [modules/RTC/TraceablePeerConnection.js] <A.close>: Closing TPC[1,p2p:false]...

Logger.js:154 2020-06-05T21:50:08.484Z [modules/RTC/TraceablePeerConnection.js] <A.close>: Closing TPC[2,p2p:true]...

Logger.js:154 2020-06-05T21:50:08.522Z [modules/xmpp/strophe.jingle.js] <g.onJingle>: on jingle source-remove from a@conference.mely.com.np/focus

1. <iq xmlns=​"jabber:​client" type=​"set" to=​"654ebc67-d2f5-4b4a-a44f-320848360f72@mely.com.np/​a1b848dd-09bd-431c-b22e-3d71141853b3" from=​"a@conference.mely.com.np/​focus" id=​"NjU0ZWJjNjctZDJmNS00YjRhLWE0NGYtMzIwODQ4MzYwZjcyQG1lbHkuY29tLm5wL2ExYjg0OGRkLTA5YmQtNDMxYy1iMjJlLTNkNzExNDE4NTNiMwBNZlp2eS0xMTY5AOE+TJEhol/​KJnMIHJm8mpQ=">​…​</iq>​

Logger.js:154 2020-06-05T21:50:08.532Z [modules/xmpp/xmpp.js] <A.connectionHandler>: (TIME) Strophe disconnecting: 451976.5000000043

Logger.js:154 2020-06-05T21:50:08.533Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: Disconnect was called because: undefined

Logger.js:154 2020-06-05T21:50:08.548Z [modules/RTC/BridgeChannel.js] <RTCDataChannel.e.onerror>: Channel error: undefined

Logger.js:154 2020-06-05T21:50:08.550Z [modules/RTC/BridgeChannel.js] <RTCDataChannel.e.onclose>: Channel closed by client

Logger.js:154 2020-06-05T21:50:08.572Z [modules/xmpp/xmpp.js] <A.connectionHandler>: (TIME) Strophe disconnected: 452016.87000000675

Sorry. I figured out the solutions my self.
My VPS server had not opened 10000/udp port. So after i opened it, it is working.
So, All other people, if you are not using behind NAT you dont have to use NAT configuration.