Authentication required and roomName with JWT

Hello,
i have my own installation (docker) and i’m using with jwt (everyhing working right).

1 - When i don’t put the jwt parameter in the url, an authentication dialog appears, is it possible to not show this dialog? (i’m catching the connection error event, but this dialog appears first)

2 - When i do not put the room name in the url, it creates a random roomName? Is it possible to change this behaviour?
2.1 - When i try to access to my url like this (without room name)

https:my_jitsi_url?param=something

it keeps adding a random roomname over and over.

Thank you.

For (1), if you only ever want to allow access with JWT, one option would be to “abuse” the tokenAuthUrl config to redirect access without a token to a static landing page. For example:

tokenAuthUrl: '/static/authError.html',

That param is meant to allow you to redirect unauthenticated access to another app where users might log in and get redirected back with a valid token, but no reason why it cannot be used for a static error page either.

As for (2), no idea what’s the best way to tackle that. Several options come to mind:

  1. enableWelcomePage: true then replace the content with something you want to show instead
  2. If you’ve gone for the tokenAuthUrl mentioned above, then you could choose to do nothing. Anyone landing on / will still get redirected to a random room, but they then get redirected away to your chosen landing page. This however won’t work if they also provide a jwt get param (they stay on random page but see an auth error message).
  3. Or if you’re not averse to compiling your own version of jitsi-meet, the least hacky solution would be to change this line here:

Thank you very much. I will try that.

Hello shawn,

in which file is this?

Best, Daniel

/etc/jitsi/meet/your.domain-config.js

1 Like