Authentication not working

Hello,

I have a problem that the authentication on my Jitsi server is not working.
I installed Jitsi with the quick install on a Debian server. Then I worked through the part “Secure domain” from this link: https://github.com/jitsi/jicofo#secure-domain
But I can still open new meetings without authentication.

My jicofo/config:
JICOFO_HOST=localhost
JICOFO_HOSTNAME=jitsi.XXX.com
JICOFO_SECRET=XXX
JICOFO_PORT=5347
JICOFO_AUTH_DOMAIN=auth.jitsi.XXX.com
JICOFO_AUTH_USER=focus
JICOFO_AUTH_PASSWORD=XXX
JICOFO_OPTS=""
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -$

My jitsi/meet/config.js:
var config = {

  • hosts: {*
  •    domain: 'jitsi.XXX.com',*
    
  •    muc: 'conference.jitsi.XXX.com',*
    
  •    anonymousdomain: 'guest.XXX.com'*
    
  • },*
  • bosh: ‘//jitsi.XXX.com/http-bind’,*
  • clientNode: ‘http://jitsi.org/jitsimeet’,*
  • testing: {*
  •    enableFirefoxSimulcast: false,*
    
  •    p2pTestMode: false*
    
  • },*
  • enableNoAudioDetection: true,*
  • enableNoisyMicDetection: true,*
  • desktopSharingChromeExtId: null,*
  • desktopSharingChromeSources: [ ‘screen’, ‘window’, ‘tab’ ],*
  • desktopSharingChromeMinExtVersion: ‘0.1’,*
  • channelLastN: -1,*
  • enableWelcomePage: true,*
  • enableUserRolesBasedOnToken: false,*
  • p2p: {*
  •    enabled: true,*
    
  •    stunServers: [*
    
  •        { urls: 'stun:meet-jit-si-turnrelay.jitsi.net:443' }*
    
  •    ],*
    
  •    preferH264: true*
    
  • },*
  • analytics: {*
  • },*
  • deploymentInfo: {*
  • },*
  • makeJsonParserHappy: ‘even if last key had a trailing comma’*
    };