Authentication Error - Incorrect Username and Password

Hello everyone,

I have set up a Jitsi server for use, which works fine, until I try to set up an authentication feature.

I followed the exact same steps in the instructions: https://www.digitalocean.com/community/tutorials/how-to-install-jitsi-meet-on-ubuntu-18-04 .

But whenever I try to login as a host with a username and password combination that I registered using

sudo prosodyctl register user your_domain password

It says:

Error Incorrect Username and Password

Please let me know if you would like to see the config files for troubleshooting.

1 Like

I have same problem, do username has to be in email format? I used just username
Any help?
Thanks in advance

PS
I already solved it , incase someone needs help follow:

  1. check file /etc/jitsi/jicofo/config with following information:

sets the username to use for XMPP user logins

JICOFO_AUTH_USER=focus

sets the password to use for XMPP user logins

JICOFO_AUTH_PASSWORD= password

Now register focus user with
sudo prosodyctl register focus jitsi.server.com password
you have to use this password when login
I still have to do some research to find how can add additional users

I am having the same issue. Followed all the configuration settings to the T, triple checked them all and every time I try to authenticate as the host I get a message saying incorrect username and password. Is there something that I am missing?

@ladyalu check the user and password, which is stored in /var/lib/prosody/yourdomain/accounts

Hope you have used internal_plain which stores password in plain text.

Internal_hashed does not store in plain text.

That directory doesn’t exist.

I hope you have checked for that directory by replacing yourdomain with the actual domain name you are using.

If you are using prosody, that directory should be present.

If you are trying this on the latest stable version and are willing to reinstall, you may install using https://raw.githubusercontent.com/pregalla/jitsi-meet/jitsi-installer/jitsi_ubuntu_setup.sh

Make sure you say yes for ‘secure domain’ when prompted.

I finally found a directory that had it on there. Apparently the password was different than I had typed in the prosodyctl command.

Thanks for the assistance though. I think if I did this again I would definitely use the latest version if it is easier.
I got it working though so thanks for the help.
This was extremely time consuming trying to find the answer.

Where was the directory?! Please.

Guys, I had $ signs in my password and it would not work. /var/lib/prosody/fqdn/username.dat.
If you manually change the .dat file it will work. Just follow the official jitsi guide and it should be fine.

return {
        ["password"] = "Password";
};