Autenticated users and unauthenticated users in the same conference

I have some users that have login and password.
I want those to have admin and moderator rights.
can they invite anonymous users as simple attendants without passwords to their conference ?
how can I configure this ?

There is no such thing as admin/moderators. When authentication is enabled users are moderators, has more stuff they can do. When enabling secure domain, you can enable anonymous domain so you can invite guests. https://github.com/jitsi/jicofo#secure-domain

problem being it is not asking for a password anymore…

cat /etc/prosody/conf.d/video.wdemo.cloud.cfg.lua
– Plugins path gets uncommented during jitsi-meet-tokens package install - that’s where token plugin is located
–plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

VirtualHost “video.wdemo.cloud”
– enabled = false – Remove this line to enable this host
authentication = “internal_plain”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/video.wdemo.cloud.key”;
certificate = “/etc/prosody/certs/video.wdemo.cloud.crt”;
}
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
}

    c2s_require_encryption = false

VirtualHost “guest.video.wdemo.cloud”
authentication = “anonymous”

Component “conference.video.wdemo.cloud” “muc”
storage = “memory”
–modules_enabled = { “token_verification” }
admins = { “focus@auth.video.wdemo.cloud”,“otheruser@video.wdemo.cloud”}

Component “jitsi-videobridge.video.wdemo.cloud”
component_secret = “XXXXXXXXXXXXX”

VirtualHost “auth.video.wdemo.cloud”
ssl = {
key = “/etc/prosody/certs/auth.video.wdemo.cloud.key”;
certificate = “/etc/prosody/certs/auth.video.wdemo.cloud.crt”;
}
authentication = “internal_plain”

Component “focus.video.wdemo.cloud”
component_secret = “XXXXXXXXXXXXXXXX”

another problem… when it was asking for a password I couldn’t invite any anonymous users

plus …
I have used the jitsy script to install a letsencrypt cert and…
systemctl status prosody

  • prosody.service - Prosody XMPP Server
    Loaded: loaded (/lib/systemd/system/prosody.service; enabled; vendor preset: enabled)
    Active: active (running) since Thu 2019-12-19 13:58:26 CET; 32min ago
    Docs: https://prosody.im/doc
    Main PID: 530 (lua5.2)
    Tasks: 1 (limit: 1065)
    Memory: 18.3M
    CGroup: /system.slice/prosody.service
    `-530 lua5.2 /usr/bin/prosody

Dec 19 13:58:26 video systemd[1]: Started Prosody XMPP Server.
Dec 19 13:58:42 video prosody[530]: portmanager: Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281
Dec 19 13:58:42 video prosody[530]: portmanager: Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

please help

Preformatted textJicofo 2019-12-19 15:37:04.986 SEVERE: [54] org.jitsi.jicofo.discovery.DiscoveryUtil.discoverVersion().200 Failed to discover version, req: <iq to=‘jitsi-videobridge.video.wdemo.cloud’ id=‘MqQ99-49’ type=‘get’><query xmlns=‘jabber:iq:version’></query></iq>, response: <iq to=‘focus@auth.video.wdemo.cloud/focus6418233722’ from=‘jitsi-videobridge.video.wdemo.cloud’ id=‘MqQ99-49’ type=‘error’><error type=‘cancel’><service-unavailable xmlns=‘urn:ietf:params:xml:ns:xmpp-stanzas’/></error>”`