AudioLevels from remote participants not updating, remains 0

Description:

Trying to get realtime audioLevel values from remote participants to trigger a Noisegate that modifies respective’s remote track volume when this is above/below the given threshold and show the audio meter in each thumbnail.

Using iFrame API.

ConfigOptions : {
resolution: 480,
constraints: {
video: {
height: {
ideal: 480,
max: 480,
min: 240
}
}
},
startWithAudioMuted: muteOnJoin && [‘audio’, ‘both’].includes(muteOnJoin),
startWithVideoMuted: muteOnJoin && [‘video’, ‘both’].includes(muteOnJoin),
channelLastN: 8,
enableLayerSuspension: true,
disableAudioLevels: false
}

InterfaceConfigOptions: {
APP_NAME: ‘Circus app’,
SHOW_BRAND_WATERMARK: false,
SHOW_POWERED_BY: false,
SHOW_PROMOTIONAL_CLOSE_PAGE: false,
DISABLE_VIDEO_BACKGROUND: true,
TOOLBAR_BUTTONS: [‘videobackgroundblur’],
DISABLE_FOCUS_INDICATOR: true,
DEFAULT_REMOTE_DISPLAY_NAME: ‘Fellow team member’,
DEFAULT_LOCAL_DISPLAY_NAME: ‘me’,
SHOW_JITSI_WATERMARK: false,
DEFAULT_BACKGROUND: NeutralColors.gray200,
SHOW_WATERMARK_FOR_GUESTS: false
}

Steps to reproduce:

  1. Add console.log(audioLevel) in Thumbnail.js in order to check the realtime audioLevel of each participant.

Expected behavior:

For each participant logs an audioLevel value that change depending on the audio signal intensity

Actual behavior:

AudioLevel = 0 for all participants

Server information:

  • Jitsi Meet version: master
  • Operating System: Linux

Client information:

  • Browser / app version: Chrome and Firefox / latest versions
  • Operating System: MacOs BigSur 11.2.3 and Windows 10

Additional information:

When running Jitsi-Meet in local it works ok, it gives the current audioLevels and it’s updating constantly. When using the iFrame API audioLevels values remains always 0.

Question:

Are there some config options I’m missing to enable/disable?
Is there another way to get realtime audioLevels using iFrame?

Thanks in advance! :slight_smile: