Audio/Video not working on latest version of JVB 2.0.7577

I noticed after upgrade of JVB and Jicofo, Prosody to latest versions.

jitsi-videobridge_2.2-18-gade06bf8    2.0.7577 

root@ip-172-31-45-160:/etc/jitsi/videobridge# dpkg -l|grep jitsi
ii  jitsi-meet-prosody                 1.0.5913-1                        all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-tokens                  1.0.6380-1                        all          Prosody token authentication plugin for Jitsi Meet
ii  jitsi-meet-web-config              1.0.5913-1                        all          Configuration for web serving of Jitsi Meet

root@ip-172-31-45-160:/etc/jitsi/videobridge# dpkg -l|grep prosod
ii  jitsi-meet-prosody                 1.0.5913-1                        all          Prosody configuration for Jitsi Meet
ii  prosody                            0.11.8-1~focal1                   amd64        Lightweight Jabber/XMPP server

root@ip-172-31-45-160:/etc/jitsi/videobridge# dpkg -l|grep jicofo
ii  jicofo                             1.0-862-1                         all          JItsi Meet COnference FOcus

No audio/video calls, no screen sharing is working.

I investigated a little and what I can see is that Jicofo is not listening on port 5347.
In /etc/jitsi/jicofo/config there is configuration set for that.

netstat, ss, lsof all showing it is not listening on that port.

Older version of JVB 2.2-9-g8cded16e-1 works well!

Did you get any error during the upgrade?

No errors at all.

Start-Date: 2022-08-09  09:04:17
Commandline: apt-get upgrade -y
Requested-By: ubuntu (1000)
Upgrade: (0.104-0ubuntu2~20.04.1, 0.104-0ubuntu2~20.04.2), update-notifier-common:amd64 (,, snapd:amd64 (2.54.3+20.04.1ubuntu0.3, 2.55.5+20.04), ubuntu-advantage-tools:amd64 (27.8~20.04.1, 27.9~20.04.1), isc-dhcp-common:amd64 (4.4.1-2.1ubuntu5.20.04.2, 4.4.1-2.1ubuntu5.20.04.3), jitsi-meet-tokens:amd64 (1.0.6260-1, 1.0.6380-1), libnetplan0:amd64 (0.104-0ubuntu2~20.04.1, 0.104-0ubuntu2~20.04.2), unattended-upgrades:amd64 (2.3ubuntu0.1, 2.3ubuntu0.3), isc-dhcp-client:amd64 (4.4.1-2.1ubuntu5.20.04.2, 4.4.1-2.1ubuntu5.20.04.3)
End-Date: 2022-08-09  09:04:31
Unpacking isc-dhcp-client (4.4.1-2.1ubuntu5.20.04.3) over (4.4.1-2.1ubuntu5.20.04.2) ...
Preparing to unpack .../2-isc-dhcp-common_4.4.1-2.1ubuntu5.20.04.3_amd64.deb ...
Unpacking isc-dhcp-common (4.4.1-2.1ubuntu5.20.04.3) over (4.4.1-2.1ubuntu5.20.04.2) ...
Preparing to unpack .../3-netplan.io_0.104-0ubuntu2~20.04.2_amd64.deb ...
Unpacking (0.104-0ubuntu2~20.04.2) over (0.104-0ubuntu2~20.04.1) ...
Preparing to unpack .../4-libnetplan0_0.104-0ubuntu2~20.04.2_amd64.deb ...
Unpacking libnetplan0:amd64 (0.104-0ubuntu2~20.04.2) over (0.104-0ubuntu2~20.04.1) ...
Preparing to unpack .../5-ubuntu-advantage-tools_27.9~20.04.1_amd64.deb ...
Unpacking ubuntu-advantage-tools (27.9~20.04.1) over (27.8~20.04.1) ...
Preparing to unpack .../6-snapd_2.55.5+20.04_amd64.deb ...
Unpacking snapd (2.55.5+20.04) over (2.54.3+20.04.1ubuntu0.3) ...
Preparing to unpack .../7-unattended-upgrades_2.3ubuntu0.3_all.deb ...
Unpacking unattended-upgrades (2.3ubuntu0.3) over (2.3ubuntu0.1) ...
Preparing to unpack .../8-jitsi-meet-tokens_1.0.6380-1_all.deb ...
Unpacking jitsi-meet-tokens (1.0.6380-1) over (1.0.6260-1) ...
Setting up snapd (2.55.5+20.04) ...
Installing new version of config file /etc/apparmor.d/usr.lib.snapd.snap-confine.real ...
snapd.failure.service is a disabled or a static unit not running, not starting it.
snapd.snap-repair.service is a disabled or a static unit not running, not starting it.
Setting up update-notifier-common ( ...
Setting up isc-dhcp-client (4.4.1-2.1ubuntu5.20.04.3) ...
Installing new version of config file /etc/apparmor.d/sbin.dhclient ...
Setting up libnetplan0:amd64 (0.104-0ubuntu2~20.04.2) ...
Setting up jitsi-meet-tokens (1.0.6380-1) ...
Setting up (0.104-0ubuntu2~20.04.2) ...
Setting up unattended-upgrades (2.3ubuntu0.3) ...
Installing new version of config file /etc/kernel/postinst.d/unattended-upgrades ...
Setting up isc-dhcp-common (4.4.1-2.1ubuntu5.20.04.3) ...
Setting up ubuntu-advantage-tools (27.9~20.04.1) ...
Installing new version of config file /etc/ubuntu-advantage/uaclient.conf ...
Created symlink /etc/systemd/system/ → /lib/systemd/system/ubuntu-advantage.service.
Processing triggers for libc-bin (2.31-0ubuntu9.9) ...
Processing triggers for systemd (245.4-4ubuntu3.17) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for dbus (1.12.16-2ubuntu2.2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Log ended: 2022-08-09  09:04:31

Jicofo is no longer using that port, it now connects as an XMPP client to Prosody over port 5222.

Do you see any errors in the browser JS console?

Only these ones with bandwidth upload/download.
Other errors are fine I think.

You need to upgrade all components, selective upgrades are not advised.

iOS app is upgraded to latest. I will test later iOS Jitsi <-> iOS Jitsi

No, not the apps. If I read you correctly, you upgraded JVB, Jicofo and Prosody, you did not upgrade Jitsi-Meet. You need to update the entire Jitsi stack together, make sure they’re all running on the latest version (or at least, that all the versions match the same release).

Eventually I did that. But I reverted JVB after it failed…

I will do it in couple of hours and let you know about the outcome.

Thank you Freddie!

I did it. I have same problem.

Can you share the full browser console logs? gUM fails and it’s not clear to me why.

Yes I can do that, if you need.

GUM fails because I opened link on Linux Desktop which doesn’t have Camera and Microphone … That is why it failed. That is normal.

I have PC and MacBook. On PC I was just testing screen sharing …

What else beside browser logs do you need?

I see my config.js has 2 obsolete things:
openSctp: true,
openBridgeChannel: “datachannel”

var config = {
    hosts: {
        domain: "meet.[REDACTED].com",
        authdomain: "meet.[REDACTED].com",
        focus: "[REDACTED].com",
        muc: "[REDACTED].com",
    clientNode: "",

    disableSimulcast: true,
    enableRemb: true,
    enableTcc: true,

    resolution: 360,
    maxFps: 20,

    constraints: {
        video: {
            frameRate: {
                max: 20,
            height: {
                ideal: 360,
                //ideal: 180,
                max: 720,
                min: 180,
            width: {
                ideal: 640,
                //ideal: 320,
                max: 1280,
                min: 320,

    externalConnectUrl: "//meet.[REDACTED].com/http-pre-bind",

    enableP2P: false,
    preferH264: true,
    p2p: {
        enabled: false,
        preferH264: true,
        disableH264: true,
        useStunTurn: true, // use XEP-0215 to fetch STUN and TURN servers for the P2P connection

    useStunTurn: false, // use XEP-0215 to fetch TURN servers for the JVB connection
    useIPv6: false, // ipv6 support. use at your own risk
    useNicks: false,

    bosh: "//meet.[REDACTED].com/http-bind",
    websocket: "wss://meet.[REDACTED].com/xmpp-websocket",

    // One of true, 'datachannel', or 'websocket'
    // openBridgeChannel: "datachannel",
    // openBridgeChannel: 'websocket',

    clientNode: "",
    desktopSharing: "webrtc",

    desktopSharingSources: ["screen", "window", "tab"],
    desktopSharingChromeDisabled: false,
    desktopSharingFirefoxDisabled: false,
    desktopSharingFrameRate: {
        min: 5,
        max: 15,

    useRoomAsSharedDocumentName: false,
    enableLipSync: false,
    disableRtx: false, // Enables RTX everywhere
    enableRtpStats: true, // Enables RTP stats processing
    enableScreenshotCapture: false,
    enableStatsID: true,
    minHDHeight: 480,

    startBitrate: 128,

    useRtcpMux: true,
    useBundle: true,
    disableSuspendVideo: true,

    // Audio
    disableAP: false,       // disable ??
    disableAEC: false,      // disable echo suppression and cancellation
    disableNS: false,       // disable noise suppression
    disableAGC: false,      // disable automatic gain control
    disableHPF: false,      // disable high pass filter??? (no lower-than-speech sounds)

    stereo: false, // stereo sound
    disableAudioLevels: true,
    forceJVB121Ratio: -1,
    enableTalkWhileMuted: true,
    enableNoAudioDetection: true,
    enableNoisyMicDetection: true,
    mouseMoveCallbackInterval: 1000,

    enableClosePage: true,

    transcribingEnabled: false,
    requireDisplayName: true,
    isBrand: false,
    logStats: false,

    enableUserRolesBasedOnToken: true,
    enableLayerSuspension: false,

    testing: {
        enableFirefoxSimulcast: true,

    deploymentInfo: {},

    rttMonitor: {},

    e2eping: {
        pingInterval: 10000,

    remoteVideoMenu: {
        disableKick: true,

    flags: {
        sourceNameSignaling: false,
        sendMultipleVideoStreams: true,
        receiveMultipleVideoStreams: true

    videoQuality: {
        preferredCodec: 'VP9',
        maxBitratesVideo: {
            VP8: {
                low: 200000,
                standard: 500000,
                high: 1500000
            VP9: {
                low: 100000,
                standard: 300000,
                high: 1200000
    useNewBandwidthAllocationStrategy: true,

    disableRecordAudioNotification: false,
    disableJoinLeaveSounds: false,

    enableClosePage: false,
    enableWelcomePage: false,
    enableDisplayNameInStats: true,
    pcStatsInterval: 3000,

    enableForcedReload: true,

    enableRecording: true,
    fileRecordingsEnabled: true,
    fileRecordingsServiceEnabled: false,
    fileRecordingsServiceSharingEnabled: false,
    recordingType: "jibri",

    hiddenDomain: "[REDACTED].com",

    enableRtpStats: true,
    openSctp: true,
    channelLastN: 6,
    startVideoMuted: 80

The browser logs might show the failure in detail, that’s why I asked :slight_smile:

Here you go.

2 browser log files. As there should be at least 2 users in conference …

client1.log (16.8 KB)
client2.log (19.9 KB)

Thank you for your help

Looks like you might have some permissions issue.

Same version of Chrome, with same permissions works on Jitsi stack version before latest.
I tried iOS <-> iOS. As iOS App is compiled from same React code…audio doesn’t work there as well, all permissions are given properly.

I have the same issue. I only changed (all) our docker images to the latest version (stable-7577-2) and audio / video no longer works.

1 Like

If anybody is interested into helping resolving this issue.
I can share URL’s for testing in private messages.