Audio not working with a lot of users

@damencho i just test with two user. Here whats happening 1st user is working fine using self hosted jitsi meet but its not working on rocket chat app integrated with jitsi meet. 2nd user work find using rocket chat app but its not working in the self hosted. Hope this help!

1st user

Statistics RTCIceCandidate_uWnp/6hb
timestamp 11/5/2019, 6:59:57 PM
transportId RTCTransport_0_1
isRemote true
ip 52.43.236.86
port 59284
protocol udp
candidateType relay
priority 24977151
deleted false

2nd User

Statistics RTCIceCandidate_wRd37h9/
timestamp 11/5/2019, 9:15:16 PM
transportId RTCTransport_audio_1
isRemote true
ip 45.77.109.40
port 4443
protocol ssltcp
candidateType host
priority 2130706431
deleted false

The first one is in p2p directly connecting to the second client. The second connection shown is using bridge tcp connection, it is strange that they do not connect directly in the second case … Are both using same deployment? Are both tests on same network for both clients?

Hello @damencho,

Sorry for the confusion. Here is the new log running the same deployment. Clients is running different networks. Do you think setting up turn server will help to resolved this issue?

Self-hosted Jitsi

webrtc logs

1st user rtc logs
PH

RTCIceCandidate_YVAZFHwe (remote-candidate)
Statistics RTCIceCandidate_YVAZFHwe
timestamp 11/7/2019, 9:23:08 AM
transportId RTCTransport_audio_1
isRemote true
ip 45.77.109.40
port 4443
protocol ssltcp
candidateType host
priority 2130706431
deleted false

RTCIceCandidate_m0G+KNeQ (remote-candidate)
Statistics RTCIceCandidate_m0G+KNeQ
timestamp 11/7/2019, 9:23:30 AM
transportId RTCTransport_audio_1
isRemote true
ip 45.77.109.40
port 10000
protocol udp
candidateType host
priority 2130706431
deleted false

2nd User Logs
Location - Edmonton, Canada Browser Working

RTCIceCandidate_Xb22d4vQ (remote-candidate)
Statistics RTCIceCandidate_Xb22d4vQ
timestamp 11/6/2019, 6:24:49 PM
transportId RTCTransport_audio_1
isRemote true
ip 45.77.109.40
port 10000
protocol udp
candidateType host
priority 2130706431
deleted false

3rd Users Logs - Browser Not working
Working using rocket chat app integrate with jitsi

Location - Rauch, Minnesota

RTCIceCandidate_3e1jKILk (remote-candidate)
Statistics RTCIceCandidate_3e1jKILk
timestamp 11/6/2019, 7:43:12 PM
transportId RTCTransport_audio_1
isRemote true
ip 45.77.109.40
port 4443
protocol ssltcp
candidateType host
priority 2130706431
deleted false

Not sure, as I’m not sure what is not working in which case …
If the same participant (in the same network) is using ssltcp port 4443 and this fails, then disabling TCP support in the bridge and deploying a turn server is worth the try.

I suppose rocket chat app you are talking about is using electron, so I don’t see why using the app or chrome will make a difference … the only difference is electron is few versions behind chrome …

3rd participant browser is not working. All participant is not connected to the same network. I tried to disable TCP connection using this command it’s still not working
/etc/jitsi/videobridge/sip-communicator.properties
org.jitsi.videobridge.DISABLE_TCP_HARVESTER

Is there any other command i need to add /etc/jitsi/videobridge/sip-communicator.properties

You are always experiencing a problem from one browser(chrome right?) from one participant and is always just that participant does not receive or send any audio and any video? Have you tried from another computer in the same network where the problem is? And if you do the same experiment with meet.jit.si you don’t see the problem?

its just that participant audio and video not working using browser using my self hosted jitsi meet but when we use rocket chat app its working that’s why its really weird. If i tried meet.jit.si its working fine using the same browser.

Do you think i need to setup firewall rule for port 4443 to allow tcp connection?

If you mean on the jvb, yes.

Yep, indeed. Do you know the versions of chrome that you tested with and the electron that is running inside that app?

@damencho
I did a couple of test different users it seems is not accepting ssltcp even port 443.

Yep, indeed. Do you know the versions of chrome that you tested with and the electron that is running inside that app?

How can I check that?
Is it ok to setup turn server the same host in jitsi-meet?

So you haven’t open abd forwarded port 4443 for your clients? Open it and try again.

Hello Damecho,

I open it still not working. Can i host turn server same server as jvm jicofo?

If you want to use port 443, no.

There is an option, to run and multiplex on nginx level serve web or send traffic to turnserver to but is complicated setup and I’m currently working on automating this, to be the default jitsi-meet installation.

Damecho,

What is your preferred specs for turn server?

Regards,

Romeo

Same as the bridge I would say. For meet.jit.si we use c5.xlarge from aws.