Audio not working with a lot of users

Hello,

I have a self-hosted jitsi meet server. it working fine when doing a video conference with 3-5 users. When we try to do video conference with around 20 users some user audio is not working. I’m new in jisti hoping someone can guide me what do i need to check.

Regards,

Romeo

Is it just audio? What are the resources cpu/ram and bandwidth for the server? Have you monitor them in a problem call?

Hello @damencho,

Just the audio. It works fine with a few user when a lot of user is connected in a conference call thats the problem arise some of the user is not able to hear anything some of them can hear it.

CPU:

1 vCore

RAM:

2048 MB

Storage:

55 GB SSD

Bandwidth:

[5.14 GB of 2000 GB]

If you are hosting on the same machine jvb and jicofo, my advice is to make it at least 8GB of Ram.

@damencho do you think its has something to do with the specs? How many user can my server have with simultaneous calls? I just use this guide to setup a jitsi-meet in vultr https://www.vultr.com/docs/how-to-install-jitsi-meet-on-ubuntu-18-04-lts

So jvb and jicofo are two process that when started they set the max memory that they can use up to 3GB


-Xmx3072m
So you just leave memory and for the rest of the processes and have 6 for this.

Normally the first limit to hit is bandwidth, and bandwidth and CPU usage is proportional.
Not sure what is the CPU that is used, but running the instance on aws’s c5.xlarge should handle a lot of concurrent sessions.

thanks for the info @damencho will do a test and update you soon possible.

hello @damencho,

By the way i forgot to inform you. When were doing the conference call with a lot of user we are using the rocket chat app that been ingrate with jitsi meet.

Regards,

Romeo

Hello @damencho,

When i check the ram usage in the server using with multiple session im not hitting bottle neck. Upon further checking it seems this issue only arise with the user that is using the browser. When they are using our rocket chat app integrate with jitsi meet its works fine. Any idea what should check?

What browser Chrome? Firefox?

@damencho i just did some test again with 3 users that having audio issue. Its also not working on browse using chrome and rocket chat app. When checking im not hitting the bottle neck of my memory.
image. I noticed im getting this error message in each user fellow jitsi having connectivity issue

So this message is shown normally when we stop receiving packets from that participant. So you had audio issue, but video was still flowing? Can it be that those participants really had network connectivity issues? Have observed what was the bandwidth that was used on the server when this happen? If you overload server’s link you can start seeing big packets loss and dropped streams like this.
You didn’t answer my question, what are the server Internet bandwidth, what is the upload and download link is it 20-50-100 Mb/s or 1GB/s?

I did a test again with one user audio and video are not working on my self hosted jitsi meet.
It works fine with https://meet.jit.si/. I don’t think so we did a speed test and the speed is quite ok and also the latency there is no timeout.

How can I see this big packet loss? Sorry for asking dumb question im quite new at this.
When doing speed test in my server im getting Download 4493.57 mbit/s and Upload 4.17mbit/s.

thanks for your patience and help.

So the upload is quite low, this upload is enough for feeding just one participant with one high resolution video and few thumbs. Trying to use this for more than one participant and you will start to see packet loss, high latency, stopping streams - which means seeing connectivity issues.

We also tried disabling the video just to test the audio still not working. Any idea what else i need to check? Its just weird it works with other users but in this particular user its not working.

Test again with him on meet.jit.si and check whether it uses turn, maybe he has a restrictive firewall and its udp is blocked. And his connection falls back to turns TCP connection.

How can i check if its using turn https://meet.jit.si/? I’m not really an expert.

So in his local stats (when expanded) you can see whether p2p is used (p2p) or turn (turn) in the rest of the cases where there is no such string it goes through the bridge and you can see the bridge address there.
To check whether is using TCP or UDP the best to check is to open chrome://webrtc-internals on the client machine before opening the conference and there you will see one or two tabs for the conference, one is the the peer connection for p2p and the other one to the bridge. The one where you see of sending bytes you can see information for the protocol used (not that simple, you need to get the transport and find it and to match it to selectedCandidatePairId and for that pair look at the remote candidate and see the protocol … )
image
This is currently mine using udp connected to the bridge.

Thanks @damencho will do some test.

When checking the conference I’m not able to see transport. I manage to check all RTCIceCandidate and its all running UDP jitsi meet. The weird thing is now working in the browser-based not in the app. Using MACOS Mojave on the rocket chat app.