Audio issue when joining conference via mobile browser, other participant not able to speak/hear

I am facing below issues, which are muting participants when joined via mobile browser

  1. While in call, it’s getting muted automatically in between call.
  2. Android 10 - Able to listen, but not able to speak while using in browser, no popup coming to enable microphone

@damencho your view on this as we are facing same issue

@Jaipal_kaushal have you tried searching through the forum? There are a number of similar posts. You might find the fix for your issue in one of them.

1 Like

@Freddie Thanks for response, I tried all forums but solutions provided is not working, we still facing issue as mobile browsers fails to detect audio hardware most of times. Your guidance can support.

What browser(s) are you using? Have you tried different browsers to perhaps zero it down to a specific browser?

@Freddie We are using Chrome browser on Android mobile and Safari for iOS.
Issue occurs whenever we plug and unplug earphone or do any other event like screen share all. We found same issue on Jitsi.meet as well.

@Freddie :slight_smile: we are eagerly waiting the reply for issue raised by @Jaipal_kaushal . Requesting to you ,please suggest shot of solution to resolve .

@Freddie : Need your expertise support in this regards, is there any way to stabilize Audio issue on Google chrome and safari browsers.

  1. Echo start coming some time when participants increases from 4 to 5
    2.If users try to switch from microphone and setting sometimes they unable to hear each other.

LOL… I’m by no means an expert, just an enthusiastic Jitser. :grin:

Are you having this issue on the public instance at meet.jit.si or on your self-hosted Jitsi?

For the echo issue, you can try enabling echo cancellation and see if that helps. If you have a self-hosted Jitsi, add the following to your config.js file:

disableAEC: false,

If you’re using the public Jitsi at meet.jit.si, you can add this as a URL param

meet.jit.si/your_room_name#config.p2p.enabled=false&config.disableAEC=false

You of course also want to make sure there’s no mechanical interference causing the echo e.g. meeting opened in multiple browsers on the same equipment, multiple equipment in close range without using headphones e.t.c…

Check the settings in your mobile browser to ensure permissions are granted for your mic. So, on your phone, go to apps (in the case of android), look for your browser name, then check its permissions to make sure it allows access to your microphone.