Apt wants to remove Apache2 when installing jitsi-meet

Hi,
I’m hoping to get some help herre, because I don’t know what I’m doing wrong.
I’m running a small server with Debian 11 and Apache2 and everthing works fine.
Now I wanted to install Jitsi-Meet. So I added the repos for jitsi-meet and prosody. Everything went fine. But when I type “apt install jitsi-meet”, i get the following:

Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  apache2-data apache2-utils augeas-lenses libaugeas0 python3-augeas
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  autoconf automake autotools-dev coturn cpp cpp-10 fonts-lato gcc gcc-10 geoip-database javascript-common jicofo jitsi-meet-prosody jitsi-meet-turnserver
  jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2 jq libasan6 libc-dev-bin libc-devtools libc6-dev libcc1-0 libcrypt-dev libdpkg-perl
  libevent-core-2.1-7 libevent-extra-2.1-7 libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libfile-fcntllock-perl libgcc-10-dev libgeoip1 libhiredis0.14
  libisl23 libitm1 libjq1 libjs-jquery liblsan0 libltdl-dev liblua5.1-0-dev libmpc3 libncurses-dev libnginx-mod-http-geoip libnginx-mod-http-image-filter
  libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnginx-mod-stream-geoip libnsl-dev libpq5 libquadmath0 libreadline-dev libruby2.7
  libtirpc-dev libtool libtool-bin libtsan0 libubsan1 linux-libc-dev lua-any lua-bit32 lua-expat lua-filesystem lua-posix lua-readline lua-sec lua-socket
  lua-unbound lua5.1 lua5.4 luarocks m4 manpages-dev nginx nginx-common nginx-core pkg-config prosody rake ruby ruby-hocon ruby-minitest ruby-net-telnet
  ruby-power-assert ruby-rubygems ruby-test-unit ruby-xmlrpc ruby2.7 rubygems-integration sqlite3
Vorgeschlagene Pakete:
  autoconf-archive gnu-standards autoconf-doc gettext sip-router cpp-doc gcc-10-locales gcc-multilib make flex bison gdb gcc-doc gcc-10-multilib gcc-10-doc
  glibc-doc debian-keyring patch git bzr geoip-bin libtool-doc ncurses-doc readline-doc gfortran | fortran95-compiler gcj-jdk m4-doc fcgiwrap nginx-doc
  dpkg-dev lua-dbi-mysql lua-dbi-postgresql lua-dbi-sqlite3 lua-event lua-ldap ri ruby-dev bundler sqlite3-doc
Die folgenden Pakete werden ENTFERNT:
  apache2 python3-certbot-apache
Die folgenden NEUEN Pakete werden installiert:
  [lots of packages] 
0 aktualisiert, 91 neu installiert, 2 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 99,9 MB von 137 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 342 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]

It’s in german, but I think it’s clear what will happen if I press enter. Nginx will be installed, Apache2 will be uninstalled. I searched the internet for a solution, but found none. From what I understand, jitsi-meet should recognise that apache2 is installed and shouldn’t force nginx upon me.

What am I doing wrong here?

That is a bug in latest stable packages, which was fixed, you can try unstable repo or wait for the new stable release, sorry for that.

1 Like

Thanks for the quick response. I’ll try unstable :slight_smile:

How far is the latest stable release with this fix included?

Probably by the end of this week or beginning of next.

1 Like

Thanks damencho