APT Update Jitsi - Configfiles changed

Every time I do a APT UPDATE from the stable PPA my configuration files changed. This ends in a non working jitsi servers. For example:

Changing /etc/jitsi/videobridge/config

  1. new Password?!?
  2. JVB_OPTS from “–apis=rest” to “–apis=,” <- so my colibri status monitoring dont work anymore

Or sip-communicator.properties
Adding a shared configsection, this section I already have in my config. This results in error in Prosody, since prosody dont know the new password.

So my question is: How can I supress the change of the config files while updating the packages. Or like other normal Ubuntu Packages, ask before you exchange files.

Regards Daniel

Similar to my issue Keep custom edits after upgrading

here is the postinstall script:


        CONFIG="/etc/jitsi/videobridge/config"

        # we don't want to regenerate config on upgrade
        OLDCONFIG="false"
        # migrate any old config found
        if [ -f "/etc/default/jitsi-videobridge" ]; then
            mv /etc/default/jitsi-videobridge $CONFIG
        fi

        if [ -f $CONFIG ]; then
            . $CONFIG
            if [ -n "$JVB_HOSTNAME" ] && [ -n "$JVB_PORT" ] && [ -n "$JVB_SECRET" ]; then
                OLDCONFIG="true"
            fi
        fi

        # debconf hostname question
        . /usr/share/debconf/confmodule

        # the default vars
        db_get jitsi-videobridge/jvb-hostname
        JVB_HOSTNAME_IN="$RET"

        # generate config on new install or when we are reconfiguring
        # and all install is different than current one
        if [ "$OLDCONFIG" = "false" ] || [ "$JVB_HOSTNAME" != "$JVB_HOSTNAME_IN" ]; then

as you see, the script is NOT supposed to change parameters upon upgrading if the server name has not been changed.
As this problem has never happened to me and since a month of reading this forum I have not yet seen someone else complain about that, can I assume that you changed the server name after the first installation ?

Actually the code that does the change is here:

It should change only if there is --apis=xmpp to remove it from apis, and if there are no setting to make it --apis=,

The idea is that we are migrating all configs from using the xmpp component to using the mucs.

Yes but I already migreated this.

### Anmelden bei dem XMPP Server
org.jitsi.videobridge.xmpp.user.xmppserver1.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.xmppserver1.DOMAIN=auth.meet.example.de
org.jitsi.videobridge.xmpp.user.xmppserver1.USERNAME=jvb-a1
org.jitsi.videobridge.xmpp.user.xmppserver1.PASSWORD=<secret>
org.jitsi.videobridge.xmpp.user.xmppserver1.MUC_JIDS=JvbBrewery@internal-muc.example.de
org.jitsi.videobridge.xmpp.user.xmppserver1.MUC_NICKNAME=JVB-A1
org.jitsi.videobridge.xmpp.user.xmppserver1.DISABLE_CERTIFICATE_VERIFICATION=true

### End of Config
#org.jitsi.videobridge.ENABLE_STATISTICS=true
#org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
#org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
#org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.meet.example.de
#org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
#org.jitsi.videobridge.xmpp.user.shard.PASSWORD=<secret>
#org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.meet.example.de
#org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=24dcb055-ba05-47f0-a6f3-5f9bbe516fca

The “### End of Config” was my end of config mark. And the Updater added this new “shard” section. So the JVB try to connect two times to XMPP. One successfull and one failed because of non existing login.