App store Rejected my app


#1

Hi All,
I am not sure if this is a good place to ask this question but I am gonna ask anyway. Yesterday I submitted my app in App Store which contains Jitsi-Meet Sdk and I got the following reply from Apple rejecting my app,

Recently, the Chinese Ministry of Industry and Information Technology (MIIT) requested that CallKit functionality be deactivated in all apps available on the China App Store.

During our review, we found that your app currently includes CallKit functionality and has China listed as an available territory in App Store Connect.

Next Steps

This app cannot be approved with CallKit functionality active in China. Please make the appropriate changes and resubmit this app for review.

If you have already ensured that CallKit functionality is not active in China, you may reply to this message in Resolution Center to confirm.

Voice over Internet Protocol (VoIP) call functionality continues to be allowed but can no longer take advantage of CallKit’s intuitive look and feel. CallKit can continue to be used in apps outside of China."

Any idea how to solve it?? we have clients from China…


#2

Hi,

Unfortunately the solution to this is either to disable CallKit completely or to not release in China.

We had the same problem with Jitsi Meet and I believe the situation was “solved” by just not launching in China.

If this is not an option you can disable CallKit entirely by setting the app mangled property to false in the JMCallKitProxy (I don’t have the code here, but it think it was called that way).

I’m not aware of a mechanism to dynamically detect China and selectively disable it, so if you find something please do let us know!

Cheers,


#3

thanks @saghul for the reply. i was able to publish the app without China for now. but I want to ask what is the consequence of disabling callkit completely?


#4

You don’t get the in-call UI that iOS provides nor the phone history integration.


#5

I am not what is that. can show me which one u talking about?


#6

Sure. It’s this one. It’s shown when you lock your device while in a call.


#7

thanks a lot @saghul