Anonymousdomain error, gray screen


#1

Hello everyone.

I installed Jitsi following the quick install guide, and then configured so only authenticated users can create rooms (authentication against an AD server).

The problem is that I do not get guest users to join the already created rooms.

I go to /etc/jitsi/meet/, edit vc1.mydomain-config.js and uncomment the line anonymousdomain: guest.mydomain , then If I try to access my jitsi installation, all I get is a gray screen.

Can someone help me?

Thanks


#2

Check your config.js for errors, usually missing comma after some of the modified hosts.


#4

Do you mean my vc1.mydomain-config.js ?

I added a comma after muc: 'conference.vc1.mydomain and the gray screen problem is now gone.

But then, when I uncomment anonymousdomain: 'guest.vc1.mydomain', and I try to create a room, I get the error You have been disconnected. You may want to check your network connection. Reconnecting in X sec…


#5

I edited /etc/prosody/conf.avail/vc1.mydomain.cfg.lua and added:

VirtualHost "guest.vc1.mydomain"
        authentication = "anonymous"
        c2s_require_encryption = false

under:

VirtualHost "vc1.mydomain"
        -- enabled = false -- Remove this line to enable this host
        authentication = "ldap2"
        -- Properties below are modified by jitsi-meet-tokens package config
        -- and authentication above is switched to "token"
        --app_id="example_app_id"
        --app_secret="example_app_secret"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/vc1.mydomain.key";
                certificate = "/etc/prosody/certs/vc1.mydomain.crt";
        }

        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
        }

        c2s_require_encryption = false

Do I have to declare c2s_require_encryption = false for each Virtualhost?

Now I can create rooms but it doesnt ask for authentication


#6

Ok got it working.

In addition to everything I did, I had to go to /etc/jitsi/jicofo/sip-communicator.properties and add:

org.jitsi.jicofo.auth.URL=XMPP:vc1.mydomain

Thanks a lot

How can I close this topic?