Anonymous Restrictions

Hi
i followed a quick install guide , created a user and password
for guest users it is prompting them for a user and password

please help, i need only administrator to control the meeting , no one else

If you have enabled “secure domain” then only someone with the username and password can administer the meeting.

Everyone will be prompted for the username and password, and, if they don’t know it, they’ll have to wait to join until the person who does know it joins.

Thank you
I enabled secure domain , it prompts for username and password for everyone even Guest

Did you add the guest subdomain as per the instructions?
Note that subdomain doesn’t have to actually exist in DNS, but you do need to configure it, perhaps you missed that step?

I did this part

a) Enable authentication on your main domain:

VirtualHost "jitsi-meet.example.com"
    authentication = "internal_plain"

b) Add new virtual host with anonymous login method for guests:

VirtualHost "guest.jitsi-meet.example.com"
    authentication = "anonymous"
    c2s_require_encryption = false
````Preformatted text`

That’s correct. Once the admin enters their username and password, the guests will be able to join automatically.

thank you , I managed to sort it out
thank you